Select to view content in your preferred language

Enable Attachments not working in ModelBuilder (error 000187)

488
2
04-24-2022 01:37 PM
Labels (1)
josh_is_fine
New Contributor III

I can't seem to get Enable Attachments to work properly in ModelBuilder. I have the tool running after the feature class is created in a GDB, but the tool refuses to run at all if it doesn't already exist.

josh_is_fine_0-1650832232574.png

 

2 Replies
RobertTaylor5
New Contributor III

I have run into this same error.  When I attempt to direct the output of a previous tool (e.g., Add Global IDs) it wants to feed that into the "precondition" field of Enable Attachments and won't allow it to be used for the input dataset.  

Screenshot 2022-11-22 134908.png

 

0 Kudos
ZachEdwards_WDSGIS
New Contributor II

Has anyone come up with an answer for this? Lol 2 years later. What's odd is that when I use modelbuilder to create a GDB, Feature Dataset, and a point, line, and area feature class, the line an area FCs have attachments by default. The point doesn't and doesn't allow me to add it after the fact. It's bizarre. I have tried preconditions and tried the logical if data exists operator for enabling an attachment on just the point feature class. Still no dice. Any help here is much appreciated!

0 Kudos