Difficulty Appending or Copy/Pasting Feature Service to Feature Service

05-12-2021 10:14 AM
Labels (2)
Occasional Contributor II

Using Pro 2.7.1, having errors transferring data from one feature service to another. 

I have a master feature service that serves as our database for a particular project. We collect data from several other jurisdictions that then need to be cleaned up and added to said database. To make the process a little easier I have a feature service set up, in an identical configuration to the master database, that those jurisdictions can drop their data into. I then will append it into the master database once it's cleaned up. 

However, there seem to be issues transferring the data over. When I use the Append tool I get 'WARNING 000594: Input feature 30: Failed to load a resource (string, icon, bitmap, etc)' When I attempt to copy/paste into layer, I get 'ERROR: code:400. Unable to apply edits. Bad syntax in request.'

Any thoughts on what gives? The warning leads you to extent issues. I have tried all of the extent types in the environment parameters to no avail. I also exported the data from the intake feature service into a feature class, to no avail. This workflow has worked previously (I create a feature class for each jurisdictions data in the same GDB, modeled on a master feature class, and then append to the feature service). 

Other strange behavior is happening with this feature service in conjunction. The data never showed up, then I removed the layer and brought it back and there were 12 versions of each of the datasets (I discarded edits after each attempt), and now those same features are ghost drawing at certain extents despite clearing the layer's cache. 

0 Kudos
1 Reply
Occasional Contributor II

Resolved (sort of). 

The error appears to be connected to having an active webhook. The feature services had webhooks active. When deactivated the operation resumed normally.