Default direction units - Parcel Fabric

157
1
11-15-2021 11:06 PM
DamianBaldwin
New Contributor

Is there a way of changing the default directions units for everywhere within ArcGIS Pro? Working within a parcel fabric the default direction units are quadrant bearings. I'd like them to default to North Azimuth to match our source data. I've found a number of places to change it (Layer properties, Options/Units, Attribute Table/Fields/Number Format) but it doesn't reflect everywhere. It's exhausting trying to set North Azimuth everywhere in a session, and I still haven't figured out everywhere.

Is it possible to change the default direction units from Quadrant Bearings to North Azimuth in a single location?

0 Kudos
1 Reply
jcarlson
MVP Honored Contributor

You can set the angular / direction units on a per-project basis in the settings.

jcarlson_0-1637074758339.png

As your post notes, however, an individual field may have its own defaults that override the project settings. And even then, certain editing tools will still default to a different unit type, such as using the Segment Deflection tool, which defaults to decimal degrees.

Part of your problem, I believe, lies in the layer templates. Certain configurations are auto-applied when you add particular kinds of layers. There is a way to make adjustments to some of these, however.

If you go into your Pro installation directory, you can find the .lyrx templates that are being applied to your parcel fabric and COGO-enabled line layers. (That's C:\Program Files\ArcGIS\Pro\Resources\LayerTemplates, for reference.) If you open, for example, the COGO_Lines.lyrx file in a text editor, you will find this section at around line 128:

...
{
  "type" : "CIMFieldDescription",
  "alias" : "Direction",
  "fieldName" : "Direction",
  "numberFormat" : {
    "type" : "CIMDirectionFormat",
    "decimalPlaces" : 2,
    "format" : "QuadrantBearing",
    "directionType" : "NorthAzimuth",
    "units" : "DecimalDegrees"
  },
  "visible" : true,
  "searchMode" : "Exact"
},
...

 

Make a backup of this file before editing it! On the off chance you break it, you'll want to be able to restore the working version. But the solution is simple: just change the value for the format key in the numberformat object.

Try changing it to DegreesMinutesSeconds (as per the Pro SDK reference) and then remove and re-add your layer to the project, see if that helps. For what it's worth, I've made numerous changes to the templates, and it has made quite the difference in certain cases. Even something as simple as setting a different default symbology or labeling can be nice.

- Josh Carlson
Kendall County GIS
0 Kudos