Create Random Points tool fails in ArcPro 2.9

288
5
Jump to solution
11-21-2021 08:53 AM
Labels (2)
DuncanHornby
MVP Frequent Contributor

All,

I've recently upgraded to ArcPro 2.9 and have noticed that when I attempt to run the Create Random Points tool it just gets stuck at Running with the progress bar constantly scrolling its blue bar. I have to crash out of ArcPro as clicking on cancel does nothing, it just says cancelling and keeps on scrolling the blue bar.

I've started a fresh project and even rebooted the computer, same issue.

I do nothing more than setting the constraining extent to the display setting and accept the default output location.

If I run the tool on another machine which is at 2.8 the tool is near instant in completing.

So my question to the user community is: if you have upgraded to Arcpro 2.9 does Create Random Points tool work for you?

I'm running on a machine with 11th Gen i7 intel processor and an rtx 3070 graphics card, 32Gb ram.

0 Kudos
3 Solutions

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

I just upgraded ArcGIS Pro to ver. 2.9.

Create Random Points works fine for me.

JayantaPoddar_0-1637524833899.png

Did you try rebooting ArcGIS Pro, or deleting the Display cache. Test with a different layer as constraining extent.



Think Location

View solution in original post

0 Kudos
DanPatterson
MVP Esteemed Contributor

2.9, similar specs,randomPoints.png

all is good

 


... sort of retired...

View solution in original post

0 Kudos
DuncanHornby
MVP Frequent Contributor

@JayantaPoddar and @DanPatterson , after further investigation I discovered that in fact every tool in ArcPro was broken, even the Add Field caused Pro to bomb out. So I un-installed everything. Downloaded the latest ISO from my.esri.com and re-installed everything. This seems to have fixed it, so I guess it was "a glitch in the matrix"? A **bleep** annoying one!

View solution in original post

0 Kudos
5 Replies
JayantaPoddar
MVP Esteemed Contributor

I just upgraded ArcGIS Pro to ver. 2.9.

Create Random Points works fine for me.

JayantaPoddar_0-1637524833899.png

Did you try rebooting ArcGIS Pro, or deleting the Display cache. Test with a different layer as constraining extent.



Think Location
0 Kudos
DanPatterson
MVP Esteemed Contributor

2.9, similar specs,randomPoints.png

all is good

 


... sort of retired...
0 Kudos
DuncanHornby
MVP Frequent Contributor

@JayantaPoddar and @DanPatterson , I have tried deleting the display cache as well as re-running the installer. But I still have the problem of the tool starting then locks up, so I have to crash out of ArcPro.

Thanks for taking the time to confirm that it works on your installed 2.9 versions. Your results would suggest some sort of machine incompatibility for me, for which I have yet to work out what the problem is.

0 Kudos
DanPatterson
MVP Esteemed Contributor

check other spatial analyst tools, it requires, SA or 3D even though it is in the sampling toolbox.


... sort of retired...
0 Kudos
DuncanHornby
MVP Frequent Contributor

@JayantaPoddar and @DanPatterson , after further investigation I discovered that in fact every tool in ArcPro was broken, even the Add Field caused Pro to bomb out. So I un-installed everything. Downloaded the latest ISO from my.esri.com and re-installed everything. This seems to have fixed it, so I guess it was "a glitch in the matrix"? A **bleep** annoying one!

0 Kudos