Cost Distance/Distance accumulation hanging

270
2
08-11-2021 11:03 PM
Labels (1)
Andrew_P
New Contributor

Hello World (first post),


I have two older desktops on which I run ArcGIS Pro. Both meet and exceed the minimum specs with the exception of GPU RAM.

The computers both run Win10 and are centrally managed university computers. Both run the same anti-virus/malware software with the same settings.

One computer is newer and has better specs (A) and runs ArcGIS Pro 2.8.1. It was my main GIS work computer.

However - both the Cost Distance and Distance accumulation tools started hanging recently when I moved beyond a limited extent (~1:3,000,000).

I copied my whole working directory to the older, slower computer (B) running ArcGIS Pro 2.8.0. I opened my project and ran both the Cost Distance and Distance accumulation tools (at my full project extent ~1:17,000,000) - using the same layers/project settings/etc. It runs slowly, but neither tool hangs.

I started down the Pro performance issues troubleshooting path laid out in https://community.esri.com/t5/arcgis-pro-documents/troubleshooting-performance-issues-in-arcgis-pro/....

However, since I have a working computer and deadlines, I have not progressed beyond running the ArcGIS Pro check specs web tool (results attached) and the PAT on the problem computer (results in summary table below).

Test RunLevel 1Level 2Level 3Platform TypePlatform VersionCPU TypeRAMGPU1GPU2
AllLevels_Aug-03-2021_1351203.85419.4214.224Windows10.0.19041Intel64 Family 6 Model 158 Stepping 10, GenuineIntel32 GBIntel(R) UHD Graphics 630  AMD Radeon(TM) R5 240      

 

I see that a 2.8.2 is out, but I see no specific mention of a fix for this type of problem.

I am wondering if anyone else has experienced a similar issue with 2.8.1?

 

Thank you,

Andrew

0 Kudos
2 Replies
DanPatterson
MVP Esteemed Contributor

Are you using the Legacy functions?

Cost Distance (Spatial Analyst)—ArcGIS Pro | Documentation

or the newer ones? for example

Distance Accumulation (Spatial Analyst)—ArcGIS Pro | Documentation

 


... sort of retired...
0 Kudos
Andrew_P
New Contributor

Thanks for the Q, Dan. Tried both on computer A - with the same result. As the Distance Accumulation tool ran first try on the old computer (B), and that is the tool that I want to use, I didn't try the legacy tool on B.

0 Kudos