Copy to raster not exporting Mosaic Dataset configuration

428
0
03-30-2021 11:22 AM
Labels (3)
lbraceromarre
New Contributor II

Hello, community:

 I have been working with Mosaic Datasets to create a mosaic of aerial images insided ArcGIS Pro (2.7.2 and did the update today 3/30/21).

My geodatabase has all the individual raster and the Mosaic Dataset. 

I created the Seamlines using the Voronoi Method. On the Display Setting, I choose "Seamline"> "First">  "Sort Ascending". So far, so good. 

Problem

The problem comes when I wanted to export the mosaic as a single raster. First, using the Export Data (Contents>right click on the Mosaic Dataset>Export Raster), the exported raster do not follow my displaying configuration (Seamline). I also tried the Copy to Raster tool and still the tool is exporting the raster without the right displaying configuration. 

 

How I solved it?

I decided to export the mosaic raster using ArcCatalog 10.6.1, and it did  exported the right raster (with the display method chosen). I did right click on the Mosaic Dataset>Export>Raster to Different Format (reference Exporting a mosaic dataset to a raster dataset—Help | ArcGIS for Desktop)

The tool Mosaic to a New Raster in ArcCatalog also exported the right raster. But the same tool in ArcGIS Pro, its not recognizing the Mosaic Dataset as  a valid input. 

 

This why I think there is a problem with the tool in ArcGIS Pro.  Anyone having the same issue? Am I doing something wrong? Thank you! 

 

Just in case, other things I  tried before using ArcCatalog: 

(1) I created a brand new mosaic dataset,  and re-imported every image and re-run the seamlines.

(2) I also created several copies of the GDB to test if something was broken on the GDB, and it did the same error. 

(3) I re-run the  Export Raster and the Copy to Raster in a brand new ArcGIS Pro project and still the same problem. 

(4) As said, I tried the Mosaic tool in ArcGIS Pro, but is not recognizing the Mosaic Dataset as a valid input. Mosaic (Data Management)—ArcGIS Pro | Documentation 

0 Replies