Chart not working

970
2
09-03-2022 01:52 PM
MarkC1
by
Occasional Contributor

I have a point layer which will not load a chart and I cannot understand why. Despite selecting the chart variables the chart panel continues to display the message "Select Variables in the Chart Properties pane to begin".

I have tried:

  • Seveal different chart types (bar, scatter plot, histogram etc.)
  • Saving the layer locally (originally it was a hosted layer on AGOL
  • Deleting all but a couple of features from the layer
  • Creating a new map and adding the layer
  • Filter by Extent & Selection
  • Restarting Arcgis Pro

I can't figure out what the problem might be. It seems like the chart is being created (e.g. the chart title and axis labels are all configure and the linear trend equation chages when I chose a different variable) but is just not visible.

 

 

 

MarkC1_0-1662237995224.png

 

0 Kudos
2 Replies
MarkC1
by
Occasional Contributor

So I figured out that it was being caused by an issue with the Alias for the esrignss_avg_h_rms field. The Alias has some leading whitespace like below, and when I clicked in to edit it the Alias dissapeared completely. ReTyping a new Alias fixed the problem! Weird but it worked...

MarkC1_0-1662240100497.png

 

ChristopherAllen
Esri Contributor

Hi @MarkC1 ,

Glad to hear you found a solution! I was not able to reproduce the bug you described in your original post. If you are able to share the project and data you were using when you encountered the bug (before you fixed the alias), that would be really helpful. If this is possible, please feel free to email me at callen@esri.com.

Thanks!

Chris

0 Kudos