Calculate Geometry broken in version 2.7?

286
5
Jump to solution
12-28-2020 01:31 PM
Labels (1)
SeanSummers_CC
New Contributor III

I recently upgraded to version 2.7 and I now have a problem using the "Calculate Geometry".  My project is in Pennsylvania State Plane (WKID = 4269) and I need to calculate the Latitude and Longitude for points as I add and edit them.  In Pro 2.6 I used the "Calculate Geometry" to do this all the time with no problem.  Nothing has changed in my data, format, or process except the update. Now I get errors :

WARNING 160096: The length of the value exceeds that of the field.
WARNING 001086: Skipping feature(s) because of NULL values in # field.

 

and then the tool just returns the State Plane feet values.  Is anyone else having an issue?  Is this a bug or has the process changed? Thanks for any insights!

0 Kudos
1 Solution

Accepted Solutions
SeanSummers_CC
New Contributor III

I ran "Check Geometry" and no errors were found.  Looking at the "Calculate Geometry" tool again this morning, I decided to try something different.  For the last year I always just changed the "Coordinate Format" option to "Decimal Degrees" and got what I wanted.  This morning instead of doing that, I manually changed the "Coordinate System" option to WGS1984 and it calculated the Lat/Long I was expecting.  I did still get the weird warning/errors.

In the end, I'm not sure if the old version was working as intended or this was something ESRI meant to change.  I could find no documentation of this change on the help site. To me they look the same for 2.6 or 2.7.  I can live with this work around, it is just confusing that when I upgraded to 2.7 this tool no longer worked in the same manner it had before.

View solution in original post

0 Kudos
5 Replies
DanPatterson
MVP Notable Contributor

Calculate Geometry Attributes (Data Management)—ArcGIS Pro | Documentation

you can now toggle between 2.7 and 2.6 help topics to see if there are any differences. (see Other versions beneath the topic title)

I would be more concerned about the warning.  I would suggest a Check Geometry and a Repair Geometry if necessary before you continue.


... sort of retired...
SeanSummers_CC
New Contributor III

I ran "Check Geometry" and no errors were found.  Looking at the "Calculate Geometry" tool again this morning, I decided to try something different.  For the last year I always just changed the "Coordinate Format" option to "Decimal Degrees" and got what I wanted.  This morning instead of doing that, I manually changed the "Coordinate System" option to WGS1984 and it calculated the Lat/Long I was expecting.  I did still get the weird warning/errors.

In the end, I'm not sure if the old version was working as intended or this was something ESRI meant to change.  I could find no documentation of this change on the help site. To me they look the same for 2.6 or 2.7.  I can live with this work around, it is just confusing that when I upgraded to 2.7 this tool no longer worked in the same manner it had before.

View solution in original post

0 Kudos
RobbynAbbitt
New Contributor III

I am having a similar problem. Since upgrading to 2.7 the Calculate Geometry tool simply doesn't work.  It runs clean with no errors, but calculates nothing.

Did anyone ever submit a potential answer to you for your issue?

0 Kudos
SeanSummers_CC
New Contributor III

Nobody ever provided a solution, and as far as I can tell there is no mention in the help documents.  I ended up changing the way I used the tool.  Basically the way I used it since I started using Pro was different since the upgrade to 2.7.  I had to select different options in the tool dialog that I normally didn't before.  It has been working for me now using this method.

Something for you to check is what format is the field that you are calculating into.  I usually use a "Double" number.

0 Kudos
gis_user
New Contributor

I am having the same issue with Calculate Geometry tool in 2.7.0 and 2.7.1 when I calculate acres. I get the same warnings (160096 and 001086). Acres are actually calculated but with the warnings. When I use the same data and calculate geometry in 2.6.0 and ArcMap 10.7.1, there are no warnings or errors. I am wondering if this is a 2.7.x bug...(?) I forgot to mention that these warnings only appear when calculating geometry (in this case acres) for a newly digitized polygon (or polygons). Calculating geometry for existing polygons does not trigger these warnings. 

 

0 Kudos