Buffer stops at 100% and then fails to execute Error 999999.

07-30-2016 11:33 AM
New Contributor II

I have a large (360,000 features, 1.69 GB) dissolved land cover dataset feature class of just the forrest cover in the James River Watershed in a file geodatabase. I am trying to perform an inner buffer (-100m) to create a feature class of core habitat. I have selected and created a new layer from this that excludes any feature with shape length less than 100m. I have projected it to the correct coordinate system and repaired geometry. However, the buffer still runs up to 100%, goes back to 0%, and then fails. I am using arcgis pro to take advantage of the 64-bit geoprocessing capability of my computer, which also has 12 GB RAM and 3GHz CPU, though I have also tried to do it in ArcMap 10.4.1. All the failed output files are 5.33 KB and task manager shows that disk usage/activity ceases once it hits 100%. The output is to the file geodatabase and the parameters are Side Type: Full....     Method: Planar....     and No Dissolve.... -100 meters. Any advice would be immensely helpful as I have been trying to get this to work for over a week.

0 Kudos
3 Replies
MVP Esteemed Contributor

well you have all the tags covered except subsample.

Have you tried with a smaller dataset?

You mention that you removed small geometries... I would run a sample using selected samples from your remaining that have an area less than 200**2 units to see if the negative buffer is causing geometry errors rather than the complete disappearance of the geometry.  (in short consider a circle negatively buffered with a radius of 100 m, in theory it should become a point and/or vanish)

You seem to have everything else covered, except trying to do this in pieces rather than process all at once.  Sometimes the incremental approach, using subsamples, can have significantly less processing times than doing the whole.

Esri Esteemed Contributor

If it works with a smaller set, then you could divide the featureclass into smaller featureclasses, perform the inner buffer and merge the results. As Dan suggested, try it with a smaller set first.

0 Kudos
MVP Esteemed Contributor

In addition to what Dan mentioned, have you tried running the 0 ft/m buffer and a positive buffer?  If a zero and positive buffer work, than you have narrowed down to something with using negative buffers with your dataset.