Attribute Selections in Pro using 'timestamp' Issue

416
8
06-01-2017 04:50 AM
LarryGaudieri1
New Contributor III

After a skim of online documentation for date & time queries (Time Expressions in Pro) I am confused. I cannot select a date range using Select Layer by Attribute and the clause function. It offers a date-picker or I can scroll to a specific timestamp but when the expression is complete (and looks valid anyhow) it continually reports an error with the expression. Am I missing something?

8 Replies
AndrewHargreaves2
Occasional Contributor III

I have this issue too - and am frustrated.

arcgis pro 2.2‌

David Watkins

0 Kudos
MichaelVolz
Esteemed Contributor

Can you supply some screenshots of what your query looks like?

What version of Pro are you using?

0 Kudos
DeenaBowman
Occasional Contributor

Hello, I'm having the same issue.  I'm using Pro 2.2.4, and the data are an ArcGIS Online hosted feature layerSelect by AttributeSelect by Attribute - SQL

0 Kudos
MichaelVolz
Esteemed Contributor

I just tested Pro 2.2.4 with a similar date query to your screenshot and it successfully executed the query.  I did this test against both a file gdb and Oracle 12c SDE database.

What is the source of your data (e.g.file gdb, enterprise SDE database, shapefile, other)?

Did you create the data yourself or import it from another source?

0 Kudos
DeenaBowman
Occasional Contributor

The data are published as an ArcGIS Online hosted layer.  I've tested with other feature layers published to AGO (by me and others) with the same issue.  I'm not having any issues with  file-gdbms, enterprise SDE or shapefiles.

MichaelVolz
Esteemed Contributor

Thanks for the additional information.  I think the key is the data is an AGOL hosted layer as this tool also fails for me in this scenario at Pro 2.2.4.

Maybe the title of this post needs to be modified to reflect the problem is narrower and based on an AGOL hosted feature layer source.

0 Kudos
DeenaBowman
Occasional Contributor

Hi Michael, I just stumbled onto this post.  I will create a new posting to reflect the AGOL component.  Thanks for confirming!

0 Kudos
MichaelVolz
Esteemed Contributor

If this is an important workflow feature for you in Pro, I would start a technical support incident with ESRI.

0 Kudos