Attachments not possible after Join made

510
3
03-24-2021 01:48 AM
Labels (1)
RosieCampbell
New Contributor

Hey all, I've been using Pro for quite some time but recently after an update (now using 2.7.2) I am having issues with attachments and joins. Layers that have a join no longer are able to have an attachment, saying ' ERROR 001400: Only the data owner may execute enable attachments.' when I try to enable or attach anything. To be clear, I am the data owner of both files and prior to the update this was no issue and in fact was able to use these same files. I can even enable and add attachments to the two layers seperately, but once they're joined the attacment (and all ability to add one) disappears. This is the case for all of my files, not just one or two. I've tried to use the 'Change Priveleges' tool to make sure everything is in order, which it is.

So is this a weird bug, and has it happened to anyone else?
Does anyone have a suggestion for how it can be fixed?

Cheers!

0 Kudos
3 Replies
TigerWoulds
Occasional Contributor III

After you do the join try exporting that to a new feature class. Then try the attachments again.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

@RosieCampbell, if this worked previously, I would recommend reaching out to Tech Support as this may be a bug.  They can log the bug for you, so that the product team is aware.

0 Kudos
Robert_LeClair
Esri Frequent Contributor

If this worked prior to installing ArcGIS Pro 2.7.2, I'd say it's a BUG as well.  Please contact Esri Support Services.  If you want to "rollback" ArcGIS Pro to 2.7.1 so it does work for you, go to your Control Panel->Programs->Programs and Features->Installed Updates and uninstall ArcGIS Pro 2.7 Patch 2 (2.7.2).  Then you will be able to work with the functionality at ArcGIS Pro. 2.7.1  Good luck!

0 Kudos