ArcPy Intellisense Not working

294
1
08-23-2021 04:09 PM
Labels (2)
Susan_McClendon_NPS
New Contributor II

I'm playing around with ArcPy and notebooks in ArcPro 2.7.3.  I'm fairly versed in python, but have not used much in Pro until now.

However, I can't seem to get intellisense working, which I find really handy when playing around with what I can and can't do for a particular module.  Versions:

python version:  3.7.10 [MSC v.1927 64 bit (AMD64)]
arcgis API version: 1.8.5
widgetsnbextension:  3.5.1
ipywidgets version:  7.6.3

ArcPro:2.7.3

I've created a clone, made sure all the packages are updated (both via ArcGIS Pro-->Python-->Update Packages and via conda install -c esri arcgis).  Python Modules look ok as does nbextensionlist.

If I look at nbextesions config in ArcPro - it lists:

ArcGIS/Extension and jupyter-js-widgets/extension as ! Possibly incompatible.

Susan_McClendon_NPS_0-1629759936579.png

I've search the forums only to find most posts are about getting the intellisense working in an IDE with the default Arc install, but nothing recently just on this out of the box issue.

Any hints would be appreciated.

TIA




Susan T. McClendon
GIS Specialist, Wildland Fire Management RD&A
National Interagency Fire Center, NPS
phone: 208-258-4244
email: susan_mcclendon@nps.gov
Tags (2)
0 Kudos
1 Reply
DanPatterson
MVP Esteemed Contributor

some issues have popped up on the arcgis api github site

arcgis-map-ipywidget@1.8.5 is not compatible with the current JupyterLab version · Issue #1017 · Esr...

I have ipywidgets-7.4.2, arcgis 1.9.0 and widgetsnbextension-3.4.2 installed

The differences between 1.8.5 and 1.9.0 in terms of dependencies are pretty small and they aren't strict for the most part

"depends": [
"ipywidgets >=7",
"keyring >=19",
"lerc",
"matplotlib",
"notebook",
"numpy >=1.16.2",
"pandas >=1",
"pyshp >=2",
"python >=3.7,<3.8.0a0",
"python-certifi-win32",
"pywin32-security",
"requests",
"requests-kerberos",
"requests-negotiate-sspi",
"requests-oauthlib",
"requests-toolbelt",
"requests_ntlm",
"six",
"ujson >=3",
"widgetsnbextension >=3",
"winkerberos"
],

If you can't find a solution, you might want to post an "Issue" on the github site

Issues · Esri/arcgis-python-api (github.com)


... sort of retired...
0 Kudos