arcpy.analysis.SummarizeWithin() fails when using a Group Field in Python script

345
2
05-27-2021 10:14 AM
Labels (2)
NoahRandolph
New Contributor

A Python script that used to properly create an 'output feature class' and 'output grouped table'  using arcpy.analysis.SummarizeWithin() no longer writes the results to the GDB.

The last time the Python script worked properly was with ArcGIS Pro 2.7. I update to ArcGIS Pro 2.8 about a week ago, so that might have something to do with it.

When I run 'Summarize Within' with a 'group field' from within ArcGIS Pro, it properly writes the 'output feature class' and the 'output grouped table' to the GDB.

However, after copying the same command, when run from a Python script, SummarizeWithin completes without errors, but does not write the resulting 'output feature class' nor the resulting 'output grouped table' to the GDB.

When I run the Python script without a 'group field', it properly writes the 'output feature class' to the GDB.

Any ideas why the 'group field' is causing this failure?

0 Kudos
2 Replies
DrVSSKiran
Occasional Contributor II

Hi,

In ArcGIS Pro 2.8 several geoprocessing tools were rewritten or enhanced to improve performance, including Multipart To Singlepart, Summarize Within, Summarize Nearby, and Append (when using feature services as input).

Please refer this link: https://pro.arcgis.com/en/pro-app/latest/get-started/whats-new-in-arcgis-pro.htm

https://pro.arcgis.com/en/pro-app/latest/tool-reference/analysis/summarize-within.htm

Thanks

Anish_Adhikari
Occasional Contributor

I am also experiencing the same problem on 2.8. I am using Pycharm IDE. When I run the script, it runs with exit code 0 but the feature class is not written to the GDB. I ran the Summarize Within tool in Pro which successfully ran and created the feature class. I then copied and pasted the code in my Python script and it is still doing the same thing. 

0 Kudos