ArcPro tile pack empty

07-25-2020 05:22 PM
New Contributor II

i have been struggling all day with ArcPro trying to share a raster as web layer via the cache local option ( which i have done before dozens of times ) but on ArcGIS online i find that there's no actual tiles to be cached !!
so i ran the geoprocessing tool to create the package myself ( different image types, different zoom levels )
i extract the tile package to inspect on windows but the package is empty and has only metadata json file with no actual levels generated !
the whole tpk or tpkx ( i tried both ) is just 9kb !!
in ArcMap same raster dataset works just fine and package is generated, i did try other rasters with Pro but same result.
i need the one generated by Pro because in ArcMap the tiles disappear after the max zoom level, while the ones generated by Pro stay on the map regardless of how much you zoom in even if the details are pixelated.

0 Kudos
1 Reply
Esri Contributor

I had the issue of having successfully created tile packages with nothing in them. These 2 things got me over this issue:

1. Fill in Map metadata (description etc). No matter how brief, as long as all fields are filled.

2. Build pyramids and statistics as stated in this article

0 Kudos