ArcPro Oracle initial connection very slow

144
0
12-09-2021 10:08 AM
AaronReisner
New Contributor

Upon installing ArcPro on a new laptop, I found the initial database connection to Oracle is extremely slow. Once connected and features are visible they load normally, but connecting to a new schema can take over a minute where it used to take 5 seconds. I tried upgrading from ArcPro 2.8 to 2.9 (and upgrading the license manager to 2021.1 to get ArcPro 2.9 to run), but I'm still having the same issue. 

Oracle client is (x64) 12.2.   Older computers on the network using Oracle 12.1 (ArcPro 2.8) connect faster, but when I tried rolling back the  to Oracle 12.1 on the new computer with ArcPro 2.8 the Oracle connection remained slow. (With ArcPro 2.9 and a Oracle 12.1, there was a database connection error.)

I've tried connecting using "Add database connection" as well using a previously saved connection string, but both have the same slow connection.

Appreciate any troubleshooting ideas. 

Tags (2)
0 Kudos
0 Replies