ArcPro 2.6 Export PDF issue

5551
14
07-29-2020 10:32 AM
MichelleWilliams1
Occasional Contributor III

Hello,

I downloaded 2.6 because I heard a BUG I facing is fixed. But when I export a PDF, they won't open.

Do you have any ideas?

Troubleshooting:

  • I exported a PDF with and without georeferenced data
  • I exported a jpg without any problems.

Tags (1)
0 Kudos
14 Replies
JeffreySwager
New Contributor

We are getting the exact same error. Those in my group who are running 2.5 can export the same layout to PDF with no issues.  We called tech support yesterday and the short answer was it was a network issue, and to work around it they suggested moving all of the data over to a local drive which isn't a fix but a really inconvenient work around.  When the data was moved over to a local drive the export to PDF did work but we can't have all of our data stored locally so it isn't an option for us.  We are putting the 2.6 upgrade on hold for our organization.  Those who have upgraded to 2.6 can export to jpeg with no issues, so in the mean time we can export to jpeg and convert to PDF.  

0 Kudos
MichelleWilliams1
Occasional Contributor III

Thank you for replying. Here's more troubleshooting.

  • Print to jpg without a map series is Working
  • Print a jpg with map series the PDF writer stops here (and I upgraded my PDF software today)

  • Print PDF without a map series is Working
  • Print PDF with a map series Not Working

  • Exported PDFs with and without Map Series won't open.
0 Kudos
AaronFalk
Esri Contributor

Hi Michelle. 

Can you share a screenshot of your export to pdf and/or print to pdf settings? I would like to try and reproduce the problem and haven't been able to thus far.

Do see the problem if you BOTH export to PDF (share Tab > export layout) and print to PDF (share Tab > Print Layout > Adobe PDF as the printer)?

Also, what is the layout size and is there any other information about the setup you can share? Any images in the layout inserted etc?

 My Adobe Acrobat Pro DC is a bit newer is the only obvious difference so far other than the data and layout elements:

0 Kudos
TimothyBarnes
Occasional Contributor

For what it's worth, I am getting the same issues however:

Exporting a layout newly created within Pro 2.6 using Share>Export layout (either from ribbon or catalog view) does work

Exporting a imported layout using either ribbon or catalog view does NOT work. These layout files (.pagx) have been

created in previous versions of pro, but have been re-saved from their master project using 2.6

Exporting a map, associated with the imported layout above does work

Exporting anything using 'Print' does work.

So, I suspect it's something to do with both the Export function and issues within projects created in previous versions of pro, even if they have subsequently been opened and saved in v2.6.

0 Kudos
MichelleWilliams1
Occasional Contributor III

Good day to you, as of this morning my PDFs are opening again. I guess the stars aligned this weekend on when I re-tested everything this morning it worked.

Thank you, everyone, for helping me through this issue.

I did create a new project and a clean layout before printing this morning. Thank you, Timothy Barnes!!!

0 Kudos
TimothyBarnes
Occasional Contributor

Edit- There's another thread (https://community.esri.com/thread/257602-export-layout-to-pdf-that-includes-tif-logo-fails-in-pro-26 which indicates that having a tiff image included in a layout will cause the export to fail. This is what was causing mine, removing the tiff file solved it or using the 'Print' button worked too.

AaronFalk
Esri Contributor

Thanks Timothy. I was going to follow up asking about TIFF's as there was a recent issue logged for this that development is aware of: BUG-000132706- Inserting a TIFF into a report or layout results in incorrect behavior on export

To workaround this currently, using another image format should work. Such as PNG, BMP or JPG file format for images.

Another option that is reported to work is to use Print from the Share tab of layout and use 'Microsoft Print to PDF" and save the file.

Apologies for the inconvenience. 

JohnDiaz
New Contributor II

I just wanted to express that the exporting layout to PDF issues continue with Pro 2.6.1.  All my layout templates and projects I've been using since 2015 will not export to PDF, only to image files (JPEG, etc.).  The behavior I see is that the PDF begins to export, then Pro locks the file up at 4 KB, making it corrupted.  

I had to redo all of my layout templates and that seemed to work.  Caution for those of you with this issue: Do not try to copy/paste elements from a previous layout. It will make the issue persist.  Build layout from scratch. 

Hopefully this issue will be resolved.  I've got some layouts that took me weeks to complete that I cannot export to PDF and it hurts so bad.

0 Kudos
MichelleWilliams1
Occasional Contributor III

I had the same issue, and it looks like your need to print to a PDF instead.

0 Kudos