ArcGIS Pro- Statistics Don't Respect Record Selection

589
4
08-04-2023 09:52 AM
Amanda__Huber
MVP Regular Contributor

Hello Pro Team, 

We've encountered an issue in Pro 3.1.2  that we were told/tested to be resolved in ArcGIS Pro 3.1 . When testing this in ArcGIS Pro Holistic, this behavior was resolved. 

The issue- 

When selecting records then running the Statistics tool, the statistics tool does not respect the record selection and shows statistics for the entire feature layer: 

Amanda__Huber_0-1691167821361.png

For example the sum of our selection of trails are not 552.8 miles

Amanda__Huber_1-1691167879071.png

NOTE: Our data is stored in an Enterprise Geodatabase

Can this please be addressed and resolved?

Thank you, 

Amanda Huber

 

4 Replies
SarahRijneke
Occasional Contributor

You can also use the data engineering pane to calculate statistics. Click on your layer in the contents pane then press ctrl+shift+d. Drag a field into the middle of the screen and click the calculate button and scroll over until you see the sum column. You will need to click the calculate button every time you make a new selection in your table to only see the sum of the selected values.

BarryNorthey
Occasional Contributor III

The Statistics worked fine on my test fgdb layer but failed as in your example when using the equivalent layer from a mobile geodatabase. The Filter: Selection chart option was greyed out in the latter. I saw in another thread where egdb's seemed to have thrown the same problem. It might be related to the format of your data source.

Amanda__Huber
MVP Regular Contributor

Good point, we're using Enterprise Geodatabases. This could be something only affecting certain types of databases. I'll add that as a note to the original post. 

0 Kudos
MikeSautkulis
New Contributor III

I came across this thread after an experience similar to the OP. I am using a mobile geodatabase however. I don't recall ever having this issue with any fgdbs in the past. Would be great if all supported database formats were treated equally.

0 Kudos