ArcGIS Pro Project does not save UNC path

2512
3
Jump to solution
09-23-2018 08:47 AM
CherylTrine
Occasional Contributor II

I am using Arc Pro 2.2.1 and trying to create a custom project template that has my database connections all set up for my personal use on one computer (i.e., not for use on multiple computers or shared with others), and a map that uses some data from those databases. The databases are on a networked drive. I do not want the data copied into the project template, I need to be able to access the original database data for editing.  Consequently, after trial and error and Professor Google, I learned I need to use the full UNC path in setting up the database connection.  Apparently, I don't know how to do that, because when I fill in the form, "Select Existing Geodatabase" as follows:

and then create a template, being sure to check the box "save template to file", and not checking "Share outside of organization", it still packages up the database to the project folder, because when I open the newly created project template, go to properties and look at the source for the Fiber_edit.gdb, it points to the project folder C:\...\ArcGIS\Projects\fibertest\fibertest.gdb, instead of my network drive.  If I have a map with data from the database, it points to the project fibertest.gdb instead of the network .gdb.  (The system works fine for my enterprise SQL database, but not for file geodatabases.)

What am I doing wrong?

1 Solution

Accepted Solutions
CherylTrine
Occasional Contributor II

I was using the the Share>Project Template from the ribbon, so now, after seeing there is a Consolidate Project tool, I tried that.  I made sure "Package As Template" was checked, but the problem is the same.  I think it has to do with the connection somehow NOT saving as UNC--even in my original project, the source for the database is shown as local path, with drive letter, rather than UNC.

I finally figured it out!  In the window for Select Existing Geodatabase, type/paste the complete UNC from Windows Explorer into the Name field. Don't do anything with the browsing field at the top of the form; when you browse to the file geodatabase, even though it initially looks like a UNC path, if you click in the field you will see it replace the host name/sharename with the drive letter, and that is where the problem lies. 

Where is this documented--how to get a UNC path for a file geodatabase connection into Pro?  Am I the only one who can't find it, and spent a lot of time trying multiple different methods of trying to use a UNC path before finally hitting on the right one?

View solution in original post

3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

UNC paths are mentioned in this link

Consolidate Project—Data Management toolbox | ArcGIS Desktop 

don't know if that is where you are, but it does mention the  "package_as_template" in light of the unc path issue

0 Kudos
CherylTrine
Occasional Contributor II

I was using the the Share>Project Template from the ribbon, so now, after seeing there is a Consolidate Project tool, I tried that.  I made sure "Package As Template" was checked, but the problem is the same.  I think it has to do with the connection somehow NOT saving as UNC--even in my original project, the source for the database is shown as local path, with drive letter, rather than UNC.

I finally figured it out!  In the window for Select Existing Geodatabase, type/paste the complete UNC from Windows Explorer into the Name field. Don't do anything with the browsing field at the top of the form; when you browse to the file geodatabase, even though it initially looks like a UNC path, if you click in the field you will see it replace the host name/sharename with the drive letter, and that is where the problem lies. 

Where is this documented--how to get a UNC path for a file geodatabase connection into Pro?  Am I the only one who can't find it, and spent a lot of time trying multiple different methods of trying to use a UNC path before finally hitting on the right one?

JoeBryant1
Occasional Contributor II

We are finding the same thing: Pro uses your computer's registry to display folder connections in the browse window that APPEAR to be UNC paths. But when you add these sources to a project, or click in the path bar, you will see that Pro is actually using the mapped drive letter! This causes multiple problems when working with a team across a network, attempting to publish data from an ArcGIS Server verified data store, as well as the problem Cherly describes above. I have not found a way to make Pro use the UNC path by default in the Browse window; I have to type in the full UNC path. I am hoping to provide a solution to our users so that they can navigate to a file using the Browse window and have Pro save the UNC path instead of the mapped drive letter.

Here is an example of what we are talking about; the folder connections listed under "Computer" are the supported locations listed under "This PC" when using Windows File Explorer (Windows 10, Pro 2.7.1). The locations are presented to the user as UNC paths, but clicking in the path bar reveals that Pro is only referencing the mapped drive letter short-cut.

JoeBryant1_0-1621036410523.png