ArcGIS Pro not updating attribute table, folder/file structures, gdb contents, etc

07-21-2017 12:39 PM
Occasional Contributor II


I am noticing that in ArcGIS Pro (2.0, but in previous versions as well) when I run a tool that adds a field, that field isnt showing up in the Attribute Table when I open the layer/feature class that the tool was run on.

Example: I ran the Geoprocessing tool "Add Geometry Attributes" and after I run the tool, there is no new field that shows up in my attribute table.  I need to quit out of Pro and reopen for that field to show up in the attribute table.  

This follows a similar course with Pro not updating the folder trees or geodatabases when a feature class is added from outside of Pro (example if I move or create a feature class in ArcMap, Pro doesnt see it until I quit out of Pro, or manually refresh). However, there is no way to manually refresh an attribute table that I am aware of - so the only course of action is to quit out of Pro.  I think there is a lingering bug here that Pro is not "seeing" changes that are made to file structures, folder structures and attribute tables.  I think this behavior needs further investigation by ESRI and the QA/QC team.  I was hoping this would have been addressed in 2.0 but apparently the team is not aware of this issue.

I am wondering if others can also repeat this behavior

Tags (1)
0 Kudos
4 Replies
New Contributor III

Tyler, I have the same experience with adding then calculating fields, but I think only when executed from model builder.  When the tool is execuated separately and the table is opened *after* processing finishes, the new field and values appear.  They will not appear if the table is in an open window.  Is that what you mean by a manual refresh?


0 Kudos
New Contributor III

Tyler, this question is similar to one that I have with Versioning in Pro.  I'm using versioned editing in ArcMap and my changes to the DEFAULT version (after Reconcile & Post, Refresh) do not show up in Pro.  The layers in Pro are not in editable workspace so the Version tools aren't available.

UPDATE for Versioned Editing:

  • Condition 1, Editing taking place in ArcGIS Pro: I created a new map in the ArcGIS Pro project and added an editable layer, changed to a child version and made edits.  Performed R&P and refreshed on the Versioning ribbon.  Switched over to the non-editable map (same ArcGIS Pro project) > switched to "List by Data Source" in the Catalog > Selected the DEFAULT version in the catalog tree for the layer that was just edited > Selected the Versioning tab on the ribbon > hit the "Refresh" button > Success!  LOTS of steps compared to a single click on the Versioning toolbar in ArcMap.  I hope this gets streamlined.
  • Condition 2, Editing taking place in ArcMap: Once the data is edited, R&P in ArcMap, ArcGIS Pro requires that layer to get Reconciled and saved before the changes made in the ArcMap session are refreshed (Posting not required).

If I'm missing something in the ArcGIS Pro workflows/tools, please let me know (and I'll delete this post!).  I've looked high and low for a better method and nothing worked.

0 Kudos
MVP Esteemed Contributor

I don't know about versioning and the stuff... but... there is a refresh button (circling arrow) in many places or text 'refresh' in others (tables geodatabases etc etc)

right-click ... refresh if it is there or click on the button.

This observation is shared perhaps because things like some edit steps have to be saved before they are kept and a few other instances.  I don't notice any more... I just hit refresh whenever I see it... sometimes just to keep my thoughts clear

0 Kudos
Occasional Contributor III

Actually this is happening quite frequently again in the latest 2.8.2 release. Right now I'm staring at a selected polygon that has been deselected in the map, but is still highlighted no matter what I do in layout mode until I quit and re-open Pro. 

The same thing happens when editing too, I will change the name of a point, then name changes in the attribute field and I save the edits. The point label however does not change no matter how many times I turn labeling on/off, hit refresh, edit some more hit save, etc. - it simply will not update until I quit out of Pro and re-launch. I think there is some buggy something in there that has not been addressed for a while - this post is pretty old.

Happened for me a couple versions ago, seemed to go away, but is back with a vengeance in 2.8.2.