ArcGIS Pro layout legend not displaying layer name when label is turned off

01-25-2022 08:02 AM
Labels (1)
New Contributor III

I am trying to display a simple, single-symbology map layer on a legend layout, with the layer name 'LNP Boundary'. When I have both the 'Layer name' and 'Label' boxes ticked in the Element pane for that layer in the legend, the layer name displays fine, as in the screenshots below, where the box is the outline of the legend:



However, I want to display the layer name, not the label. The problem is that whenever I untick the 'Label' box in the Element pane, the label text disappears, but the layer name only partially displays:




I can't work out why this is happening, as there is obviously enough space in the legend to display the layer name. The only workaround I have found is to have both 'Label' and 'Layer name' ticked in the Element pane, and then change the font for the label text to 'No color' to make it invisible. This works, but I would still like to know why I cannot display a layer name without the label switched on. Any ideas welcome.






Tags (3)
0 Kudos
4 Replies
MVP Regular Contributor

@YusefSamari Im sorry you've been having issues with this. You're not alone, as the Pro legend can be somehwat of a minefield when it comes to getting the perfect setup and losing text in the 3 red dots is certainly a cause for heartache for many Pro users!

Have you tried adjusting the fitting strategy of the whole legend to see if this brings the text back into view? Which strategy are you using?


Also, I tend to fix the font size on my legends and have the text a bit smaller. That'll help any overspill.


..Maps with no limits..
0 Kudos
New Contributor III

Hi David, thanks for the quick reply. My fitting strategy is 'Adjust columns and font size' but I have tried all 5 fitting strategies and none of them bring the text back into view. I can't see how the font size should make a difference, seeing as it's the same font size with the 'Label' box ticked on or off. It is something that I could play around with though. For now I am managing fine by changing font of the label text to 'No color', but thought I would see if anyone had any obvious ideas as it's bugging me!


0 Kudos
MVP Notable Contributor

Yusef, I know it doesn't seem intuitive but could you try increasing the size of the "word wrapping" to see if that helps widen your words? I know it says for labels and descriptions but I wonder if it would stretch out your layer names too:



0 Kudos
Esri Regular Contributor

Hi Yusef, 

I believe you are running into a bug. Currently there is no option to set word wrapping on Layer name. However, if you set word wrapping on a legend item's Descriptions the layer name also gets wrapped - this is the bug. Layer names should not be wrapped (since there is no option to wrap them).

In your case it looks like you have word wrapping on for both items Descriptions. Since it appears you have no descriptions to wrap I would suggest turning off this option.

Hope his helps,


0 Kudos