ArcGIS Pro Label Placement grayed out in SCENE

4115
21
09-19-2017 08:06 AM
PeteCoventry3
Occasional Contributor

I'm using Scene in ArcGIS Pro and I don't understand why my Label Placement is grayed out even though I've selected my Feature Class in the Contents panel and the Maplex Label Engine is checked? I'm new to Pro and could be missing something obvious.

screen capture

21 Replies
Robert_LeClair
Esri Frequent Contributor

Update for Pro 2.1 - the bug lives on sadly in the latest iteration.  For customers experiencing this issue, you may associate your Customer ID with the bug by calling Esri Support Services.  With more customers added to the bug, perhaps it will be resolved sooner.

BradTyberg
New Contributor

25Feb2018

Maplex Label Engine not working (enabled but all action buttons greyed out in content pane) for ArcGIS Pro Advanced 2.1.1.10257 

Look forward to fix asap

thx ESRI

0 Kudos
CalvinKwon1
New Contributor III

Has there been any update to this issue?

0 Kudos
JustinMcCubbin1
New Contributor

Nope. Still having the same problem in Pro 2.2.3

deleted-user-KeCekUcGoK9m
New Contributor II

Hi, I'm having a similar issue here. I'm labeling points in a Scene but all the options are grayed out - I can't even select options from the Label Placement. I tried with different features - same thing. I'm currently using ArcGIS Pro 2.3.0

0 Kudos
Robert_LeClair
Esri Frequent Contributor

If you move it into the 2D layers of the Contents Pane, does the Label Placement UI not gray out?  Please advise.

0 Kudos
deleted-user-KeCekUcGoK9m
New Contributor II

HI Robert. Thanks for your reply.I just moved it to the 2D Contents Pane and nothing changed in the Label Placement options. I moved it back to the 3D pane and now the labels are on top of the points - which is fine, but I'd like to make some changes on the "Position" section, but they are still grayed out.

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Hi Eduardo - so in reviewing the bug report with other customers via Support Services, I've learned there is an enhancement request ENH-000119346 (Allow option to disable ArcGIS Pro 3D scene labels showing through buildings at street level."  At first read, it seems unrelated, but in a deeper review of the request, it does reference the BUG in this thread and mentions that later releases will focus more on 3D labeling.  So this means that this issue is with us for the near term sadly.

deleted-user-KeCekUcGoK9m
New Contributor II

Robert, thanks again for your fast reply. Got it, thanks for letting me know - I will work my way around this issue.

Thanks!

JoannaMerson1
New Contributor II

The issues  with not controlling label placement are improved, but live on in 2.4.

These are labels that I had to create in the 3D layer. The label placement buttons look greyed out, but if you expand to open the full label panel you can change the position here. 

However, the alignment options still don't work. I'd really like to be able to center my multi-line labels.