arcgis pro geoprocessing tool stuck at 100%

Jump to solution
03-24-2020 05:28 AM
New Contributor III

I am using the copy features geoprocessing tool. Copying a hosted feature layer to a local fgdb, with attachments so it should churn for a while but....
The progress bar jumps to 100% quite fast but then just sits there. See screenshot. It's been at 100% for 20 mins. 

What is happening here?

ArcGIS Pro 2.5
arcpy.env.maintainAttachments = False
arcpy.env.autoCommit = 500

geoprocessing tool progress bar at 100%for 20 mins

0 Kudos
16 Replies
MVP Regular Contributor

You really should open up pgAdmin, the database manager tool of PostgreSQL, to truly see what is going on. E.g., if you deleted only a selection of the rows of a (very) large table, and the Delete Row tool triggers a VACUUM FULL on your table, then PostgreSQL may have spend the excess 34 minutes re-writing the entire table in the background to remove dead tuples / rows and optimize the table by re-claiming disk space.

Some database operations are inherently costly, and may not show progress (although it would be a good thing if geoprocessing tools in applicable cases and where possible showed at least a warning message if such situations are occurring).

Note that in case you intend to delete all rows of a table, the Help justly recommends using the Truncate Table tool instead, which will be must faster / instantaneous.

Occasional Contributor

I have been in pgAdmin for other tasks today but how do you see the status of a running tool and what it is triggering?

Appreciate the information about Help and the Truncate Table tool too!

0 Kudos
MVP Regular Contributor

Hi Adam,

Note that you will not see the actual geoprocessing tool listed in pgAdmin. Instead, the ArcSDE application is what handles the SQL communication in the background with PostgreSQL.

To access that information in pgAdmin:

- Click on the database in the left pane

- Click on the Dashboard TAB in the right pane if it isn't already visible

- In the Server activity pane on the bottom, choose Sessions if it isn't active

- In the displayed list of sessions, look for your user name and / or IP address in the User / Client columns and a session with "ArcSDE" in the Application column.

- Check that the State is active. In the example below, only the postgres user has an active status, but this was just an example screenshot. Idle sessions should be ignored, they are no longer active.

- Click on the little black arrow in the third column of the display of an active session to open a drop down that shows the Details of the active session.

- You can now see the SQL being executed at this moment.

Note that the Server activity details pane is not automatically refreshed, use the refresh button in the top right of the details pane to update it.

It is easiest to do all of this on a database not used by hundreds of other users, as you will immediately see the proper user / IP address, instead of potentially hundreds of sessions in the Server activity pane.


Occasional Contributor

Hey Marco,

Your a legend, this is super helpful.

Will definitely help confirm that the task has not frozen.

0 Kudos
New Contributor II

Hello, I am experiencing the same issue when trying to create a space time cube from a multidimensional raster layer using the geoprocessing tool. How is this issue resolved? Thank you!

0 Kudos
New Contributor

I tried to execute raster to point using dem 250m as input raster and it got stuck at 100% for a long time - more than an hour. I aborted and tried again a few times and also didnt work out.  I have also tried the solution proposed here - set the environment in the Python window via arcpy.env.maintainAttachments = False, and then run the tool through the Geoprocessing pane again.... it still didnt work.... any other suggestion is welcome.

0 Kudos
New Contributor

just a note to say that the input values are integer and not values


0 Kudos