ArcGIS Pro Export to PDF labels not showing up

09-14-2020 08:51 AM
Occasional Contributor III

Whenever I export my layout to a PDF, the labels don't show up. They're not in a separate label layer or anything, they're just simply labeled features. I'm using ArcGIS Pro 2.6. I'm new to Pro - is there some sort of option I need to switch on to get the labels to show when the map is exported as a PDF?

I've tested exporting to a JPG and the labels export fine that way.

Edit: I tested printing to a PDF and it worked. So exporting to a PDF must just be a bug?

Tags (1)
0 Kudos
5 Replies
Esri Contributor

Hello Molly,

I will admit I've seen quite a few export issues arise in 2.6.  However many of them were alleviated in 2.6.1 so I would recommend upgrading to see if that helps.  I looked into our internal systems for an issue similar to yours and didn't find anything upon my initial searches.   Before proceeding with the upgrade to 2.6.1 there are a couple things you can try.  Convert the labels to annotations and attempt the export again.  You will find this option by right clicking the layer in question and the option will be just below the Labeling Properties button.  This essentially creates a new layer for the labels and treats each label as its own individual feature, allowing for advanced editing capabilities.  Although that is not the purpose for which we are using it here, it is still worth a shot.  

Another quick test you could try would be to switch the labeling engine.  By default this should be set to the Maplex Labeling engine, however you can use the Standard Labeling engine and see if there is a different result.  This can be done by highlighting the feature layer in question within the Contents pane then hit the Labeling tab at the top.  On the very right side of this ribbon within the Map group these is a More button.  Click this and uncheck the "Use Maplex Labeling Engine" option.  Try the export again after doing this.  

I hope this helps!


0 Kudos
by Anonymous User
Not applicable

I am getting the same problem 1 year later. I am running ArcPro 2.8 and it gets even funkier, I am working on a Zone change which has 2 almost identical maps, the bottom one 'proposed zone change' just shows the proposal on top of the duplicated map of 'existing zone'. All the label settings are identical. They show up as below within Layout view in Arc Map.


But when I export the top map 'existing zone' does not label the APNs in the layer in the PDF as seen below. But the bottom one does.


Any ideas? Converting to Annotation is not an ideal option.

New Contributor

I had the same problem and it was because I hadn't saved edits in the attribute table. You can do so under the "Edit" tab. Does that help? 

New Contributor

Thanks, that definitely helped. Was laughing at myself forgetting stuffs like these. 😆

0 Kudos
New Contributor II

For anyone still dealing with this issue...I went through every option in this thread and nothing worked. What DID work was I created an entire new map and made sure to label before drawing the layout. My labels still weren't showing up, so I checked the extent and for some reason they were set to not show up past a certain zoom out. Once I turned that off everything turned back on. So many little subtleties to check, but don't give up. 

0 Kudos