ArcGIS Pro crashes or stops working when exporting an animation. Help!

1652
10
12-16-2020 11:00 AM
Labels (1)
alex_vanko
New Contributor II

Hello, I have created a flyover animation using a local scene with two 2D line feature classes on top of Esri's Ground and Imagery base layers. I have tried many times to export this to create an avi or mp4 video, both on my high-end laptop and a beefier workstation, and it just won't work. A couple times, ArcGIS Pro (2.6.3) has crashed after a few hours, but more often, the export gets through about 10-20% of the frames in the video and just...stops (no crash, no error message). I have let it sit for at least 24 hours, but it's just stuck. Please help! Why is this happening? I spent a lot of time on this neat animation, but it's worthless if I can't render it to video format.

Some details:

  • video is 3 minutes (4,249 frames at 24 fps)
  • 720p letterbox resolution
  • I have tried mp4 and avi formats with low to high "file size"
  • I have tried removing all non-visible layers from the map
  • the animation includes a title, a legend, and a half dozen captions that pop up throughout
  • one of the line feature classes includes a timescale attribute

Any help would be appreciated!

0 Kudos
10 Replies
Robert_LeClair
Esri Frequent Contributor

Alex - a couple things to try:

  • Update your video card drivers - many times the driver is out of date.  Go to Device Manager->Display Adapters to get the make/model of your video card.  Then go to the manufacturers website to search, download and install the latest video card driver.
  • Review the ArcGIS Pro System Requirements to see if you're PC can adequately run the application.
  • Is there a Revit file in your Map View?  If so, remove and try to export to video again.
  • Do you have a multipatch feature class in the view with transparency applied?  This may cause a crash.
  • Try the workflow on another PC to see if it's unique to your PC or ArcGIS Pro.
alex_vanko
New Contributor II

Hi Robert, thanks for your response. I found a new driver for my video card, and upgraded to ArcGIS Pro 2.7, but the issue persists. I have tried it on two different PC's as well.  I'll contact ESRI support next.

What is a Revit file, by the way? 

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Hmmm...I think you're best bet now is to work with Esri Support Services to see if they can resolve the technical issue.  So a Revit is an AutoDesk product that works with Building Information Modeling (BIM) and is supported in ArcGIS Pro.

0 Kudos
NathanShephard
Esri Contributor

Hi Alex,

Sorry you're having troubles with the export. I would also recommend checking to see if you need a video driver update. Another basic check is confirming you have enough disk space to write the file (note that an AVI file export will be much larger than an MP4 file).

For a practical / workaround thing to try, you could export your video in multiple parts. From your screenshot, the video gets to frame 1289, so you could try exporting the first 1200 frames and see if that works. If it does, you could then rinse-repeat the exports (for frames 1201-2400, etc), and merge the videos together into one file using a video editing application.

If you have access to a higher-end video editor, another way to go is to export from Pro directly to a folder-of-image-frames (eg: get 4249 JPG files in a folder) and then convert the images into a single video file.

Otherwise, I'm not sure why the export is failing for you, so I'd also recommend contacting Esri Support and logging an issue. If it is at all possible, sharing the problematic map package (with the animation) with the analyst would make it easier for them to test and debug the problem. It's possible you're hitting a bug in the software, or that a small change in the configuration of your animation could solve this for you.

Hope this helps.

-Nathan.

alex_vanko
New Contributor II

Hi Nathan, thanks for your response. I don't have a video editor, but I'll try the piece-wise export just to see if it will work. Obviously that's far from an ideal long term solution. I'll contact ESRI support next.

EgorNozdrya
New Contributor III

I have the same issue with exporting animations -

Arcgis Pro 2.7.3 and 2.8 just becoming unresponsive so I have to kill Arcgis Pro using task manager.

Task manager shows up to 100% gpu load for Arcgis Pro process.

It never generates any error logs, just become unresponsive
What I also found it does not play well if other graphic-resource hungry application are running (i.e animation export became unresponsive immediately if Leapfrog 3d or similar runs as well)

P.S.
My graphic card works flawless (nVidia Quadro p4000, latest drivers) with other applications, and system is the powerful workstation with 16 physical cpu cores (32 logical) and 100+ GB of RAM

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Although I haven't tested this, could you give it a try?

In ArcGIS Pro > Analysis Tab > Environments (Geoprocessing) > Scroll down to "Processing Type" and change it to 'CPU'. Does it make any difference?

JayantaPoddar_0-1621138346353.png

 



Think Location
0 Kudos
EgorNozdrya
New Contributor III

Thank you  Jayanta,

  Though - It looks like this option only available for geoprocessing, not for animation export/rendering

  I've set it to CPU- but Arc still using GPU before giving up - screenshot attached
  There got to be another place to choose software vs hardware animation frame rendering (I only see option DirectX vs OpenGL in the settings, not the hardware acceleration switch)

Trying to export it on laptop with different nVidia card behaves different, but also randomly lock up during export. Exported animation frames have different set of glitches, so I guess all that related to nVidia drivers and handled outside of Arc. With no option to turn on software-based rendering.

0 Kudos
PeterGeorge_GEOJobe
New Contributor II

I am still having this issue using Animation in ArcGIS Pro 2.9.2. Pro is up to date. Graphics cards are up to date. 128Gb ram, strong NVidia CUDA enabled GPU(s). Plenty of room. GIFs loaded, AVI and MP4 did not. 

The piecewise filmmaking might suffice but it will create more work for other teams. 

0 Kudos