ArcGIS Pro 2.6: “feature class to feature class” tool fails to reorder the fields,

528
6
11-05-2020 04:24 AM
JamalNUMAN
Esteemed Contributor

ArcGIS Pro 2.6: “feature class to feature class” tool fails to reorder the fields,

 

I couldn’t figure out why the “feature class to feature class” tool fails to reorder the fields.

 

In the screenshot below, F3 field is moved to be to the left of F1. As the tool is run, the output keeps the fields in their original positions!

 

What could be the issue here? Is this a bug?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
6 Replies
LeonS
by
Occasional Contributor II

I ran into the same issue using this tool when going from feature class  in a file geodatabase (FGDB) to another file geodatabase.  However, when I chose a shapefile for the output the fields were reordered. So you could probably do an intermediate step of your source data to shapefile, then copy it into your geodatabase.

JamalNUMAN
Esteemed Contributor

i hope esri experts can provide input about this

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
JamalNUMAN
Esteemed Contributor

Thanks LeonS.

 

The issue with shape files is that the names of fields are truncated as they exceed 8 characters, and thus these names get no longer meaningful

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
JamalNUMAN
Esteemed Contributor

Who has experienced this issue?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
by Anonymous User
Not applicable

I've been running into this as well. It seems like it works some of the time, but frequently won't translate the field edits made into the new feature class. Something's buggy about the dialogue box. I've found that if I enter all relevant attributes on the "Parameters" tab, then move to the "Environments" tab and make any changes, then press OK, I get nearly a 100% success rate. Any more messing around or going back and forth between tabs seems to break it, and the changes don't get applied. Hope that helps! It's certainly frustrating that the only way to change field order in Pro seems glitchy. . .

JamalNUMAN
Esteemed Contributor

This issue is also discussed here in the ideas section:

https://community.esri.com/t5/arcgis-pro-ideas/arcgis-pro-2-6-how-to-enhance-the-feature-class-to-fe...

I hope that esri experts can review the feedback of users

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos