Arcgis Pro 2.4.1: Calculate Field Error

09-16-2019 03:16 PM
New Contributor II

Hey guys just a heads up if you have not already discovered this, but if you have a joined table and try to calculate field from the joined field using Python 3, it will throw a syntax error every time. 

Just use Arcade instead, but be sure to use the proper syntax if you are doing anything aside from a straight field dump.  

Another funky observation is that if you try to validate the Arcade expression, it will say 'invalid expression', but the tool runs successfully.  See below:

0 Kudos
2 Replies
MVP Regular Contributor

John Diaz‌,

Try importing your shapefile into a GDB as a table before preforming a Join or Relate.  This can be completed many ways, such as from Catalog, right click on your GDB and select Import > Table(s).  Then perfor the join on this table in your GDB not the CSV.

0 Kudos
Regular Contributor

Thank you for this post with encouraged me to click "Run" even though I had the same error, "Invalid Expression Datasource could not be found". It indeed worked for me too!
In my case I created a join between an AGOL hosted feature service + a local GDB table and field calculated from the joined table. The validate throws the error, but it did successfully calculate. Hopefully this is fixed in 2.6

Screenshot of error

0 Kudos