ArcGIS Pro 2.3 Model Crashes

626
4
03-04-2019 06:57 AM
LindsayMaier
New Contributor III

In ArcGIS Pro 2.3, I have a model that--until Friday--was working just fine. It's a pretty simple model that performs some simple very simple tasks. Truly, nothing complicated at all, and again, the model was working just fine until about noon on Friday. Then, quite suddenly, it caused ArcPro to crash. I opened the project back up, went to edit the model, and now it crashes ArcPro whenever I try to do anything to it. I can get it to open up, but that is it. If I try to delete an item, add an item, cut/copy/paste an item, move an item, validate the model, literally ANYTHING... ArcPro crashes. Does anyone have any idea what might have happened, if there is a way to fix it, and how to prevent it from happening again? It seems like it got corrupted somehow, but I have no idea what to do about it (other than build it again from scratch). Note: there are a few other equally simple models in the project, and those still seem to work fine. Any ideas as to what might be going on with this one particular model? Thanks in advance!

4 Replies
AaronWorthley1
Occasional Contributor II

Any solution or workaround found? I've got the same thing.

0 Kudos
KoryKramer
Community Moderator

Are you able to upgrade to ArcGIS Pro 2.4.1?  I'm not sure off the top of my head if/what ModelBuilder specific crashes may have been fixed, but if you're able to, the best thing is to get on the current version and see if the crash persists.

Have you been submitting error reports with an email address when the crash occurs?  Here's a bit about how that process works: https://www.esri.com/arcgis-blog/products/arcgis-pro/announcements/arcgis-desktop-error-reporter-lea...

If you tell me what email address you included, I can search the database to find out more about the crash.  Otherwise, you can send .dmp files to kkramer@esri.com.  Find them in C:\Users\<username>\AppData\Local\ESRI\ErrorReports and attach a few of the latest .dmp files from Pro crashing.  The filename contains a date-time stamp:

Thank you!

0 Kudos
AaronWorthley1
Occasional Contributor II

  Yes- same result in 2.4 and 2.4.1. The original model was built in 2.3 though. I no longer have 2.3 installed to test there. I submitted the first crash report, but not with email. Will pull the dump files and email. Thanks!

MatthewMayfield
New Contributor II

I'm having a similar issue. I've been using 2.7.2, but tried installing 2.6 today, which did not fix the issue. It seems that once I've built a model out to contain more than just a few processes (maybe a dozen or more?) Pro will crash the next time I re-open the project. Unlike the original poster here, in my case Pro crashes immediately upon loading. I never have a chance to click anything inside the program before it crashes. I can still access the models and data from the project using other .aprx projects, but the next time I open the new project, it crashes as well. Essentially I have to create a new project for each session to access my models. I don't believe I'm using any tools that aren't available in Pro- I'm dragging all my tools out of the Geoprocessing panel- not importing anything from Desktop.

I've been sending error reports to Esri when I'm able. I emailed a couple of reports  today that failed to send through the error reporter.

Anybody else having this issue?

Thanks-

Matt

0 Kudos