ArcGIS Pro 1.4 database data preview is blank. Anyone else seeing this too?

1263
5
Jump to solution
01-27-2017 02:22 PM
alex_friant
Occasional Contributor II

I can see data in ArcCatalog preview. I can even see it in an ArcGIS Pro 1.4 map.

But I do not see the same data inside he ArcGIS Pro 1.4 preview of a Project Database feature class:

ArcGIS Pro 1.4 data preview issue

0 Kudos
1 Solution

Accepted Solutions
BrianRobeson
New Contributor III

I’ve seen this behavior in Pro 2.1 too.  You can restore the Preview functionality in the Catalog View by going to Options>Map and Scene and checking the box to Make newly added layers visible by default.Pro Options screenshot.

View solution in original post

5 Replies
TimOrmsby
Esri Regular Contributor

Hi Alex, it seems to be working as expected for me.

BrianRobeson
New Contributor III

I’ve seen this behavior in Pro 2.1 too.  You can restore the Preview functionality in the Catalog View by going to Options>Map and Scene and checking the box to Make newly added layers visible by default.Pro Options screenshot.

View solution in original post

alex_friant
Occasional Contributor II

Thanks Brian! Wow, I did not expect that to work because the "Catalog Preview" pane is not a "newly added layer" in a "Map or Scene". To me this seems like an oversight or unintended consequence of that switch. In my opinion, they should rename the settings title to "Map, Scene, and Preview", as well as add verbiage to that checkbox section: "(affects Catalog Preview map as well)". I just don't see the connection otherwise.

This is kind of unfortunate for users like me, who don't like layers turned on by default when added to a map because sometimes a layer could have hundreds of thousands of features, and if you are trying to do a lot of quick work, waiting for it to draw kind be a drag.

Anyways, thanks again for pointing out this not so obvious setting effect. I greatly appreciate it!

0 Kudos
BrianRobeson
New Contributor III

You’re welcome, Alex.

This has been logged as a bug. See Kory’s response to my post: https://community.esri.com/ideas/14843-preview-in-arcgis-pro-catalog-view-should-always-display-feature-class-geometry

Brian

MicheleHosking1
Occasional Contributor

Still not fixed in 2.2.3 then I see...