Select to view content in your preferred language

Anchor point does not snap to selected features

1572
8
06-23-2020 05:12 AM
AlexanderSchade
New Contributor

I am trying to move multiple features at once snapping them to another feature. However when trying to move the selection anchor point, it does not snap to any of the selected features, but only to not selected features, making it imposible to snap the selected features to another feature. What's weird is that when moving only a single selected feature the anchor point snaps just fine to the selected feature.

Am I doing something wrong here?

Tags (2)
8 Replies
Scott_Harris
Esri Regular Contributor

Hi Alexander,

I tried to reproduce the scenario you described, but so far, I'm not seeing the issue. We probably need more details (exact steps and more details about the scenario). If you need a quick answer, perhaps Esri Technical Support is a good option.

Are all of the features that you are trying to edit part of the same layer?

Is both editing and snapping checked on in List By Editing and List By Snapping?

Maybe try toggling the different snapping agents?

Thanks,

Scott

0 Kudos
KristinDillard
New Contributor

I am having the same issue in Pro 2.9.1. If I have multiple features selected, I cannot snap the anchor point anywhere on the selected features themselves, even if the layer the selected features belong to is checked in the 'List By Snapping' contents table. Snapping is turned on, and I tried toggling various snapping agents as well without success. I can snap the selection anchor of the selected features to elements of the other layers in the map, but not to any element of the selected features themselves. It seems as though the problem is *sometimes* resolved by saving edits, but this is not consistent.

AnneSantaMaria
New Contributor III

We are having the same issue, although it seems to be mostly tied to items in the utility network. We are editing items in a service hosted on portal. 

So our snapping settings are on, all items in the service are allowing snapping in the contents pane. 

We have a few group templates set up, we place the template in the map near where we want the grouped items to show up. Then we grab the grouped items and try to move the anchor to an endpoint on the line. The anchor will not snap. It does not matter if it is a grouped template or just a random selection set. 


0 Kudos
MahmoudAbdulrahman
New Contributor

I have also the same problem, tried every possible solution, doesn't work

0 Kudos
ChrisMavis_Dunwoody
New Contributor

ArcGIS Pro 2.9.2 - I found that the issue was related to the layer being projected on the fly. When I changed the Map Properties coordinate system (i.e. Web Mercator) to reflect the layer's coordinate system (i.e. NAD 1983) I was able to snap the anchor to the selected feature. Hope this helps!

tschwartz_RES
New Contributor II

This solved my issue.  Its clearly due to projection on the fly.

0 Kudos
Juneau_GIS
New Contributor

This worked for us, thanks for posting!

0 Kudos
DorianneDysart
New Contributor III

Yes, I have same issue in Pro 2.8.3  When moving a single entity, the anchor snaps to a point, but when I attempt to move multiple features together, the anchor will not snap to a point like first user noted. Snapping is on and layer is projected.  However, after looking at comment above, I changed my Map coordinate system to same as feature's coordinate system and it appears to be working.  I can't understand this behavior because why would the single move work?  Shouldn't this work without having to change my Map coord system?  In any case, I am happy it is working now!

DorianneDysart_0-1661962755632.png

singlefeature_move_anchor_showing_snapped

 

DorianneDysart_1-1661962789482.png

multifeature_move_anchor_showing_unsnapped

 

0 Kudos