Adding layers to a legend

519
2
Jump to solution
01-15-2022 03:20 AM
HelenCooper
Occasional Contributor III

This feels like a silly question, but I honestly can't figure out the answer to it!

If I have a legend on a layout, and it doesn't contain all of the layers from the map frame that it is linked to, is there any way of adding the layers back in?  I've had this issue a few times, and have ended up creating a new legend as I can't find a way around it, but I'm sure I must be missing something basic!

Thanks in advance for any help. 

1 Solution

Accepted Solutions
MervynLotter
Regular Contributor

HI Hellen

There may be two reasons. Either (A) the display option for the layer is unchecked under your Legend items (see below image), or (B) you need to add the layer to the basket of layers that is currently being included in your legend. 

MervynLotter_0-1642250966305.png

For B), from your Contents pane, you need to click and drag the layer into the actual legend that is included in the map layout (so that will be the legend that is shown in the exported map). It will then be included in the "basket" and it should display under the Legend items (A)

 

 

 

View solution in original post

2 Replies
MervynLotter
Regular Contributor

HI Hellen

There may be two reasons. Either (A) the display option for the layer is unchecked under your Legend items (see below image), or (B) you need to add the layer to the basket of layers that is currently being included in your legend. 

MervynLotter_0-1642250966305.png

For B), from your Contents pane, you need to click and drag the layer into the actual legend that is included in the map layout (so that will be the legend that is shown in the exported map). It will then be included in the "basket" and it should display under the Legend items (A)

 

 

 

HelenCooper
Occasional Contributor III

It was B - the layers weren't in the legend to be ticked - it had never occurred to me to just drag them from the map frame.  Brilliant - thank you very much indeed!

0 Kudos