Specify units when Exporting to CAD

2174
9
02-12-2020 02:26 AM
Status: Needs Clarification
Labels (1)
JeffVan_Etten1
New Contributor III

We recently had to export some data from ArcGIS Pro to a 3rd party and found that they were asking some probing questions about the units that the data was exported with.  We had specified that this was using (in our case) British National Grid (EPSG:27700) which uses metres as default.  However, when the data is exported, it converts the DWG units to feet and inches.  I can't see anywhere where this can be changed or set in the current interface. 

 

The only way that we can now fix this is by using Full version of AutoCAD to open the exported data.  Then using "INSUNITS" command to set this to either (4) millimetres or (6) metres.  This seems clunky and cumbersome and we should be able to specify this when exporting the data from ArcGIS Pro.  

 

Data in AutoCAD 2019:

 

Link to AutoCAD resource on this: INSUNITS (System Variable) | AutoCAD 2020 | Autodesk Knowledge Network 

 

Would expect to see a drop down list that effectively allows the user to select what units this is exported as.  Also, this should default to what ever the Coordinate Systems default unit is set to, e.g. Brit Nat Grid = metres.

 

We have tested this in ArcGIS Pro v.2.4.3 and v.2.5

 

Thanks!

9 Comments
KoryKramer

So you're using Export to CAD—Conversion toolbox | Documentation ?

That tool honors the Output Coordinate System (Environment setting)—Geoprocessing | Documentation That help goes deeper into how the default output coordinate system is determined (Spatial reference and geoprocessing—Appendices | Documentation ) but essentially in the case of the Export to CAD tool, if you give it BNG as input, it should default to BNG as output.  You can always go the Environments and set that explicitly, at least to test what's happening:

When I checked this out, and write a .dwg to British National Grid, and then add that to a map in Pro, I see that it is BNG meters.

If you add your .dwg back into ArcGIS Pro and look at the Layer properties > Source > Spatial Reference, it isn't in British National Grid with a linear unit of meters?

JeffVan_Etten1

Kory

That is correct.  I have done exactly that and read the information back into ArcGIS Pro.  However, when we send this to our CAD users, the units are in inches.  Which can be seen above in my screenshot from AutoCAD.  

The only workaround on this so far found is to use a seed file when exporting that has had this setting applied in AutoCAD.  Happy to provide some sample data to show this if needed.

What I would ideally like to see is on the environments tab, a setting there specifying the "INSUNITS" so that this can be set within the export process and not reliant on a seed file.

Thanks

Jeff

EeroSuominen

I have to confirm the problem described by Jeff in the initial post. Export to CAD tool creates CAD files with units set to inches regardless of the spatial reference settings set in the tool. These exported CAD files work just fine within ArcGIS and show correct units. But opening them in proper CAD softwares (AutoCAD, MicroStation...) shows that the units are, indeed, reverted to inches even if the spatial reference system defines them as, say, meters. The effect of this is, of course, that the generated CAD files are not spatially correct unless you happen to work with reference systems defined in inches.

The workaround for this is to use a seed file with proper units set in it, as Jeff points out. However, this workaround does not work with Extract Data and Extract Data Task tools which internally use Export to CAD tool but do not expose the option to set a seed file. So this flaw in Export to CAD tool renders Extract Data tools completely useless as well.

I think it's fair to expect that Export to CAD tool would also respect the units set by the spatial reference system the same way it respects all the other aspects of the spatial reference system. Or at the very least, a setting specifying the "INSUNITS" would be very useful, as Jeff suggested.

This default unit setting of inches is not a documented feature of Export to CAD tool and hence seems like a bug or mishap in the tool rather than a conscious design choice. Hence I hope this would get resolved in future releases of ArcGIS.

JeffVan_Etten1

Just to say, thought I would test in latest version of ArcGIS Pro 2.6.3 and the issue is still present.  Would be good to get someone from ESRI Inc to comment on this!

KoryKramer
Status changed to: In Product Plan
 
KoryKramer
Status changed to: Implemented

Hi @JeffVan_Etten1 this should be resolved in ArcGIS Pro 2.9.  Please take a look and let us know that it is working for you.

Thanks

JeffVan_Etten1

@KoryKramer

Afternoon.  Have just tested this and can confirm the issue is not fixed in v.2.9.  Brought a shapefile into ArcGIS Pro v.2.9 and tried to export this using the Export to CAD GP tool.  Shapefile source properties as follows:

JeffVan_Etten1_2-1639067211687.png

Export to CAD GP Tools settings

JeffVan_Etten1_0-1639066964194.png

and then set the environment variable

JeffVan_Etten1_1-1639067002557.png

When i read the created file into AutoCAD 2019, the insert units were reading as inches (1) instead of meters (6).

Are you able to share the workflow that has been used to test / create this?

Regards

Jeff

KoryKramer
Status changed to: Needs Clarification

Hi @JeffVan_Etten1 I'm setting this back to needs clarification as the CAD team is taking a look at your comment and will provide a response.

JeffVan_Etten1

@KoryKramer happy to help with getting this right if the CAD team more information.