Remove default value from field

1012
2
11-07-2013 01:41 PM
Status: Open
Labels (1)
RonnieRichards
Regular Contributor
You cannot remove default values from fields using a toolbox but can certainly assign them with "Assign Default to Field" but that is where we made a mistake what if you need to revert changes back? You cannot easily remove this default value.

Please create a tool that to "Remove Default from Field" because the work-a-rounds recommended by the support analysts are not reasonable. 

1) You can reapply a default value using the tool but it will not accept a blank value or the database <null> values. If the field is a string field the tool will place '<null>' in the field and this is not acceptable. It will accept space but not a blank space "" so please consider providing the option or keywords to place true <null> or blank values. 

2) You can manually remove the Default value from a field and place a blank value using ArcCatalog but never the original database <null> values again. W used arcpy and applied this default to 60 feature classes, it is not reasonable to manuall have to type in blank values for each feature class field.

3) It is not reasonable to use 3rd party tools or Xray add-ins to modify the schema and reimport the data model. This data resides in a multi-user versioned environment and this is a major change for something we thought was so simple. We used a toolbox to apply values, why can't we use the same set of toolboxes to now remove them?

4) It is not reasonable to add temporary fields, calculate values, drop the column with the default value, add the column back, calculate from the temp field, drop the temp field. This changes the field order and could cause a number of excessive records in the version tables... all for what seems to be a very simple function.

Again this seems so simple yet a tool or keywords do not exist in Assign tool to reassign the database <null> or a "" blank string as a default value once one has been assigned.


Thanks for considering!!
2 Comments
TrinaNair

I just found it.  The 'Assign Default To Field' has a check box option to "Clear Value".  Worked for me.

RonnieRichards

That worked in 10.5.1. Thanks Trina!!  wonder what version this crept in ?