Preview in ArcGIS Pro Catalog View should always display feature class geometry.

1074
8
04-16-2018 09:00 PM
Status: Implemented
Labels (1)
BrianRobeson
New Contributor III

In ArcGIS Pro 2.1, unchecking the ‘Make newly added layer visible by default’ box under ‘Options > Map and Scene’ disables the ability to preview feature class geometry in the Catalog View.

I propose that previewing a feature class in Catalog View should always display the geometry for the following reasons.

  1. Since this setting is found under ‘Map and Scene’ it’s reasonable to expect that it only applies to maps and scenes.
  2. Previewing a feature class in Catalog View is fundamentally different from a workflow standpoint than adding that same feature class to a map or scene.
8 Comments
KoryKramer

Thanks for pointing this out Brian Robeson‌.  I won't close out the idea, but I consider this a bug rather than an Idea.

I have logged the following: [BUG-000113284: Unchecking the ‘Make newly added layer visible by default’ box under ‘Options > Map and Scene’ disables the ability to preview feature class geometry in the Catalog View.]

Edit: We already had this logged as [BUG-000112514: Unable to preview the layer in Catalog View when "Make newly added layer visible by default " option is unchecked.]

Thanks again.

alex_friant

Any updates on BUG-000112514?  The latest Pro 2.3.2 still has the bug.

KoryKramer

Hi Alex,

Sorry, I don't have an update on this.  

You can go to the bug on the support site: https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDExMjUxNA==

And click the Subscribe button:

This will help with 2 things:

1. You will get notifications of status updates.

2. It will increment the count of customers watching the bug which helps to prioritize it.

Thank you.

alex_friant

Thanks for teaching me about that feature, I never knew that was a thing. Cheers!

KoryKramer

No worries.  Yeah, I think it is actually really good functionality that isn't used nearly enough.  Help to spread the word:)

Thanks

MicheleHosking1

ArcGIS Pro 2.3.3 -  this is still an issue.  Be good if there was an update on this - no information at all on the page for this bug on the support site.

KoryKramer
Status changed to: In Product Plan

Looks like this will be implemented in ArcGIS Pro 2.8: https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDExMjUxNA==

 

KoryKramer
Status changed to: Implemented

Implemented in ArcGIS Pro 2.8.

See Ideas in ArcGIS Pro 2.8 and (2:21) in the video.