Do Not Activate ArcGIS Pro Window While Loading if User has Switched Applications

1137
17
05-04-2021 03:36 PM
Status: Open
Labels (1)
NathanHeickLACSD
Occasional Contributor III

Well, I'm not versed in the proper terminology for this, but I hate it when I open ArcGIS Pro and start it loading up and then I switch to another app to do work in the mean time.  Routinely, it will reactivate ArcGIS Pro, what seems like multiple times.  If I switch from ArcGIS Pro to another app while it is loading, it should keep loading in the background and not reactivate itself. 

17 Comments
KoryKramer

Thank you for submitting this @NathanHeickLACSD 

Hmm, I just tried on 2.7.3.  I opened Pro and then started working in Word.

When Pro is ready, it flashes orange and then stays orange, but it doesn't interrupt what I'm doing.

KoryKramer_0-1620168113127.png

That is on a Windows 10 machine.

What version of Pro and what OS are you on, and do you see this happening with any application in particular?

Thanks for any additional details that you and @AnandMoka might be able to provide.

NathanHeickLACSD

Windows 10 Enterprise and ArcGIS Pro 2.7.3.  I have noticed it in one other application called WinCan, but I use it much less.  It doesn't happen in any other applications on my computer.  I am using Citrix to remote into my machine.  It takes much longer to open up the symbology pane through Citrix versus in the office.  Also, our WAB app is much snappier in the office versus through Citrix.

KoryKramer

Sorry, I meant what application are you using when Pro interrupts you by opening up "on top of it"?

 

NathanHeickLACSD

Right now, I just tried Excel.  When ArcGIS Pro gets to its start screen, it reactivates.

NathanHeickLACSD

Definitely no orange.  I've seen that on Teams, but not ArcGIS Pro.

KoryKramer

OK, I don't see that when using Excel or Word.  I wonder if it is specific to working through Citrix.

@AnandMoka since you voted on the idea, can you let us know under what circumstances you are experiencing this behavior?

Thanks

NathanHeickLACSD

Next time I go into work, I will test it.

Luke_Pinner

It's called "focus stealing" and it's very annoying. 

NathanHeickLACSD

I'm in the office this week and I am still seeing focus stealing when connected directly to my machine.  This time it was with Wing IDE.  I haven't found an app it doesn't steal focus from.  For example, it just stole it twice from Google Chrome after launching ArcGIS Pro and trying to finish this sentence.

ErinCovill1

Has anyone found a solution to this issue? I am experiencing this as well. Thanks!