Copy Parallel tool - optional copy of Z values

623
2
03-14-2011 04:52 AM
Status: Open
Labels (1)
RobJones1
New Contributor II

At present the Copy Parallel tool does not copy Z values. This means that when the Copy Parallel tool is applied to a line with Z values the new lines created by the tool are effectively placed on the ground, i.e. Z=0, and the elevation of the source line is ignored.

It would be really useful to have a check box to specify 'Copy Z value' to allow users to carry over the Zs from the source feature(s).

I understand that this issue has been captured in NIM044156 and resolved as 'software working as intended', hence the requirement for this request.
 

2 Comments
JeganSomu
I understand that this is a NIMBUS Bug. But this has been rejected because the Software is designed like that. But this idea would be great if we optionally capture z values from the features.

Users who do not have the access to the workarounds can use the below workaround to capture Z values when copying the parallel lines. But you may need the VBA License if you are using version 10.0 or if you are using version 9.x you may need to install the VBA Resources. Then you will be able to use it in the ArcMap.

Steps:
1. Open a new map document and add the data you want to edit.
2. Start an editing session with the data.
3. In ArcMap, go to Tool > Macros > Visual Basic Editor. This will open the VB editor.
4. In the left navigation window, go to the "ThisDocument" icon in Project > ArcMap Object. Double-click "ThisDocument."
5. Now copy the script below:

Public Sub ChangeCaptureType()
Dim edituid As New UID
Dim pEditor As IEditor
edituid.Value = "esriEditor.Editor"
Set pEditor = Application.FindExtensionByCLSID(edituid)
Dim pEditorZ As IEditorZ
Set pEditorZ = pEditor
pEditorZ.ZCaptureType = esriCaptureInterpolateZ
End Sub

7. Navigate back to VB Editor and paste the text. Hit Enter.
8. Close all window of VB Editor.
9. In ArcMap, go to Tools > Macros > Macros. This will open the Macros dialogue box.
10. You should see a "ChangeCaptureType" option in the Macro name window. Highlight it in the window and then click Run. Do not be alarmed if it appears that nothing happened. Actually the macro is ready to go. 11. In ArcMap, select feature with Edit Tool, then Editor > copy Parallel. Set parameters and click OK.
12. Open the attributes for the feature and view the z column. The z values should ('ve) carried over.

Hope this helps. But this can be implemented as an option when the user wanted to use "Copy Parallel".
Scott_Harris
Status changed to: Open

In ArcGIS Pro, the Copy Parallel tool does retain z-values of the source lines. We have a backlog item for having all modify tools honor the current z control (whether that’s a surface or a constant value).

As far as having the tools ignore z’s, that might be useful too. For now, the best way to remove z’s is in Edit Vertices: in the grid, CTRL+A (select all) > click ‘Update Z Values’ > set to 0.

 

Scott_Harris_0-1611339689014.png

Thanks,

Scott