Change decimal and thousand separator

2995
5
03-14-2022 07:40 AM
Status: Open
Labels (1)
LenaKroeger
New Contributor II

I would like to be able to change the displayed decimal and thousand separator so that I can create outputs for both the German (decimal separator is comma, thousand separator is point) and other markets.

 

It would be great to have the possibility to change  ArcGIS Pros separator settings without having to change my windows locale setting.

Maybe a dropdown (or something similar) in the numeric field settings where I can toggle the display of the thousand separator on and off.

5 Comments
BryndaHatch

You can toggle the thousand separator in the popup configuration pane.  

BryndaHatch_0-1647359784158.png

 

LenaKroeger

Thank you @BryndaHatch, but I already knew that.

As my original post states, my problem is not how to show a thousand separator but how to change the localization of that separator.

I want to change the separators from the German standard (decimal separator is a comma and thousand separator is a point) to the Englisch standard (decimal separator is point and thousand separator is comma).

Currently there is no option in ArcGIS to change this setting. My only option is to change my Windows locale setting globally and I would like to avoid that.

BertvanRest

Decimal comma's are also needed in Dutch spelling and also in  ArcGIS Online.

We would like to see decimal comma's in:

  • a label in a map.
  • a popup
  • etc.

and dots for thousands.

CeciliaSung

You have to change this option through user locale on a Windows operating system, which I know you have been doing. It is by designed and accurately matches with the industry standard (e.g. CLDR) 

Unicode CLDR

 

  • Locale-specific patterns for formatting and parsing: dates, times, timezones, numbers and currency values, measurement units,…

 

 

MaxsuelLopes

Hey, guys!

There is no way to change these settings directly in ArcGIS Pro, they must be changed directly on the PC settings.

Control Panel > Region > Advanced Options > Change the decimal and thousands symbol