ArcMap Comaptibility with USB display drivers

10-11-2016 03:31 PM
Status: Closed
Labels (1)
New Contributor II

We have come across a problem with ArcMap crashing on opening an mxd or switching between data and layout view for versions 10.3, 10.3.1, 10.4 and 10.4.1 when using new Dell laptop running Windows 7 x64 with only on-board Intel graphics running the latest Skylake Intel processors (for example the Dell Latitude E5470) connected to a USB docking station running Displaylink drivers.


We had extensive back and forth with ESRI support and eventually found it was due to ESRI not supporting USB 3 displaylink drivers and having no current plan to do so.


This will become a serious issue for company in 2017 (and I would think others too?) which is when I am told Dell will be withdrawing the E-port style connection found on all current Latitude models. The only option available after this time will be the use of the USB docking stations. Which will mean no new laptops will be able run ArcMap and use an external monitor. It is the driver that causes the break so just unplugging the external monitor does not allow ArcMap to run. We can potentially look at directly connecting to a monitor but with the trend in fewer ports I'm not sure that will be another display output option (or how long other options will be available for) other than USB is to some sort of adapter.


We  are a global company and this will affect users of ArcMap in several countries. Surely we are not the only ones about to run into this problem? Can ESRI look at developing support for this, if you are not already?  


Hi, did you ever find a solution to this problem? 


No, other than migrating to using Windows 10. Which in a large organisation takes time to test all existing business systems first, and how to manage the updates, especially for windows 10. 

Other options being:

1. to directly plug a monitor into the laptop, remove any dock drivers and not use docks again until using windows 10.

2. buy laptops with actual graphics cards rather than integrated graphics.


We just recently started running into this problem.  I believe we've engineered a workaround/fix for this issue (at a user-based level, it will need to be completed for every user or perhaps make it default for the user's profile/registry once you have a good default user profile/registry settings). Hopefully this fix works for you if this is has been an ongoing issue:


1) Backup the user profile on the machine under C:\users\yourusername

2) As an administrator, delete the user profile : i.e. C:\users\yourusername

3) Find the users ProfileImagePath in HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

4) Delete the entry that contains the users ProfileImagePath – i.e. C:\users\yourusername

5) Here's the workaround that got us working without uninstalling video drivers:

  1. Have the user remote desktop into the machine.
  2. Have the user open ArcMap
  3. ArcMap should open successfully.
  4. Have the user logout of the remote desktop session.

6) Now try to open ArcMap directly on the machine. We were able to reproduce the problem by running steps 1-4 and logging on the machine first directly without remote desktop, and we fixed it again by re-running steps 1-5.

7) Later: Restore any needed files from the backed up user profile.


We had success with testing Daniel's suggestion above, but our IT technician working on the issue wanted something simpler. By chance he came across the following fix which has worked for the 6 users we have tested with so far:

1) Right click desktop and select Personalize
2) Scroll down and apply the Windows 7 Basic theme
3) Scroll up and apply the Windows 7 Aero theme
4) Run ArcMap


I solved this problem for my port replicator with display link capability.

  1. Open Windows Graphic Settings
  2. Add arcmap.exe
  3. select the power saving option



Status changed to: Closed


Win 7 x64 is no longer a supported operating system by Microsoft.

If this issue is still impacting users of a supported Microsoft OS and supported ArcMap release, please report it through Esri support.