ArcGIS Pro 3D Render Distance

940
2
05-31-2017 02:22 PM
Status: Open
Labels (1)
AlexRobertson1
New Contributor II

Hi,

 

We have been generating a fair few 3D fly through videos of our city and whilst being a very effective way of communicating the information, there is something that happens which detracts from the experience for our viewers.

 

When exporting a 3D animation to a file, the renderer seems to generalise the DEM after what appears to be around 500(ish) metres away from the camera. I understand that this is likely a design decision to allow performance when rendering, but having the ground reshape itself as you move around isn't a very good look on a pre-rendered video!

 

Ideally, having an option/tick box that allows us to accept terrible performance when rendering (or a slide bar for distance) but drawing the DEM in full would be very handy. Perhaps then once ticked, each frame can be allowed to fully render prior to it being saved to the export file. Yes, it will take forever to run through the model and save it, but this can be run over night and would be fine.

 

Thanks,

 

Alex

2 Comments
SumitChowdhury

When moving a layer in a scene from the 2D Layers category of the Contents pane to 3D Layers and vice versa, it is good practice to review the scale range and distance range set for the layer. This way, you make sure your layers draw correctly when zooming in and out of the scene.

You Can check my ArcGIS TIPS AND TRICKS page: https://goo.gl/R7D5QC

AlexRobertson1

Thanks for the advice Sumit, however in this case the layers are enabled to display at all scales and most still sit in the 2D bit.

What is happening is that in 3D the layers do draw to the full extent, however after a short distance they become generalised and look all 'lumpy'. It seems to be that the DEM underneath it (from a local fgdb set as the elevation for the scene) is rendering at a lower resolution the further out it goes.

It is worth noting that this is most pronounced with rasters and data draped over the DEM. Re-reading my original post it seems that I may have omitted this information.