ArcGIS Pro 2.7.3 table editing sorting annoyance

04-16-2021 08:43 AM
Status: Under Consideration
Labels (1)
New Contributor III

When I create an asset that has a unique ID, I must sort through three feature classes to see what number I left off at. That is just the way our system is designed, and that is not the issue. Let's say that I am three fourths of the way down the attribute table. I find the last number used, so now I know what the next number will be. Returning to the map, I create the asset. In the table, I choose Show select records. Information is added to the the asset. I switch back to Show all records in the attribute table. It automatically sorts back to the beginning of the table. Now I have to scroll all the way down to where I was in the first place. This happens again and again, and it really slows down the editing process.

Many times, I want to compare a different entry with the newly created one (say to find a certain comment that I want to copy), but I don't want that entry to be selected. I only want to quickly view it and copy the comment. Switching between Show all records and Show selected records is good for what I need to do, and in ArcMap, the table stays put, meaning that I can switch back and forth between the two views and not have to do any more scrolling. In Pro, it seems like every action I do, the table sorts on me. It slows down productivity.

My suggestion is that the editing attribute tables should never automatically sort themselves. Please leave it to the user to sort when we choose to. It's already been established that scrolling is unsatisfactory, and if scrolling was set up like it is in ArcMap, I could maybe deal with the table automatically sorting, but really, it's just a hassle. 

Thank you for your consideration,



Did you find this same behavior in older Pro versions, or is this behavior new to Pro 2.7.3?

All versions.
Status changed to: Under Consideration

When you scroll a table with selected records, every time you switch between show all records and show selected records, the table scrolls back to the beginning of the table columns. Please eliminate this automatic scrolling back of the table when switching between show all and show selected. Keep the scrolling were the user had it.


I agree that I don't like that the tables unexpectedly scroll.

One thing to consider for your automatic numbering is to use a database sequence.  a database sequence will automatically add the next number as you mentioned as a need in your post.  You can see database sequences in action by downloading the Address Data Management Solution.  The solution will include an example on how Arcade can be used to populate a field using a unique value sequence.




It would be nice to turn off "auto sorting" on any table. Just place it as a toggle option in the table's context menu.

As an aside, when I'm doing thing like what you (@DonnaMoreau) are doing, I copy the layer I'm editing, turn off it's map visibility and editability, and open the attribute table on the side, and sort it the way I want it sorted. That way, when I make edits in my edit attribute table, I don't have to worry about what's going on over in the other table. I'm not 100% sure that will work for you, but maybe it will work if I read you right.


I see that this is under consideration, which is delightful and thank you! I really hope it gets implemented because it's still an issue in version 3.2.1.