Allow Surface or Ground Z Mode option in Scene

564
1
01-03-2018 12:13 PM
Status: Open
Labels (1)
TrippCorbin
Occasional Contributor

So I have been playing with 3D editing in ArcGIS Pro. During this I have stumbled on something I am not sure if it is a bug or intentional or just me doing something wrong. In a 2D map, I can set the Z mode so it will use the ground surface or any other surface I have to generate the Z coordinates for new features I create. However when I try to create new features in a 3D Scene, that option under Z Mode is grayed out and I cannot get it to activate. So I have to draw in a 2D map, then look at it in a 3D scene to make sure I am drawing it so the entire feature is visible above ground. This seems like extra work.  

Tags (3)
1 Comment
KoryKramer

Hi Tripp Corbin‌ Based on what I've heard around the office, you probably already got your answer.  For others who may run into this, here is an explanation:

In scene views, Z-enabled feature layers will get elevation values from the surface by default - assuming that there is a ground surface in the scene (such as Terrain 3D from AGOL). So you do not need to enable the Elevation mode on the ribbon for this behavior, it will happen automatically for 3D feature layers (which is why you see it grayed out/not able to select it... you don't need to).  In scene views, only the Constant Z elevation mode is supported.

 

We would like to provide users with the ability to be able to choose which surfaces to get Zs from when editing in scene views because for those who are familiar with scenes in Pro, you can provide more than one surface.  This requires some development work across multiple teams to make this happen. If/when this is in place, it will make this UX more clear since it would be consistent with how it behaves in 2D.

I hope this helps.