ArcGIS Pro 3.1 Patch 2 is Now Available

05-25-2023 11:59 AM

ArcGIS Pro 3.1 Patch 2 is Now Available

The ArcGIS Pro 3.1.2 patch is now  available for download from My Esri as well as through the software update in Pro (if enabled).

To get the latest fixes, please install this patch. For a list of issues addressed you can review the Release Notes for ArcGIS Pro 3.1

Note: ArcGIS Pro 3.1 must be installed prior to installing any ArcGIS Pro 3.1 patches. Patches are cumulative. When you install this patch, the issues addressed in a previously released patch are also included. It is not necessary to perform an incremental update of previous patches before installing this one. Here is additional information about Minor Releases and Patches 

If you have not yet updated to 3.x, please review the Migration from ArcGIS Pro 2.x to 3.0 documentation, which contains important information to consider before updating to the major release. 

New Contributor III

Hi there,
Is BUG-000157970 addressed in this patch? I cannot see it referenced in the release notes but on the technical support page it says it is fixed in version 3.1.2.



Esri Contributor

Hi @HayleyHume-Merry , yes, BUG-000157970 was fixed in 3.1.2. There was some confusion with labelling/linking of issues on our end about whether it should be included in the list. Thank you for pointing this out. The list is updated at


Frequent Contributor

Hello @RobertGarrity - I think there is a problem with the 3.1.2 patch and updating the arcgis api to version  After upgrading pro I executed the:

conda update -c esri --no-pin arcgis

process from the python command prompt after cloning  my environment.  Now the traceback in the IDLE returns an immediate 'arcggiscripting module not found error' -

so it seems that the conda update is not pulling everything down from the update.  I had to remove the cloned environment and  then re-create it, but this time I did not run the conda update.  Any suggestions?



Esri Contributor

Hi, @DavidColey. Although I'm not familiar with that, asking around flushed out the following answer: "The upgrade should be run without `--no-pin`, that can affect the package set in negative ways. I was able to create a clone on 3.1.2, then run `conda upgrade arcgis` and have both packages import correctly." 

Frequent Contributor

Hi @RobertGarrity  - yes great thank you.  That did it.  I ran 

conda upgrade -c esri arcgis

although I do not think I even need the -c esri param any longer.  The -c param is a holdover from the early days of updating the conda at Pro 1.x I think.  And yes, as far as the

-- no pin param, that again is an early holdover I used when the conda would not update because the arcgis api module was 'pinned'.  I'd mark your reply as correct and give you a kudos but as this is a 'Document' post I don't have that option...

New Contributor

Hello, new user here.  Have tried to apply this patch via ArcGIS Pro interface and alternately by downloading the .msp file from My Esri.  On each occasion I receive the following message and the update fails.


 Screenshot 2023-07-15 082036.jpg

The d: folder is shared with all users and I'm logged in as administrator.  Wondering if the error might be due to installing ArcGIS on a non-standard drive (d: instead of c:)?  Has anyone solved this issue?


Version history
Last update:
‎08-24-2023 01:05 PM
Updated by: