Curve parameter override behavior.

254
2
Jump to solution
07-17-2020 10:39 AM
JeffWard
Regular Contributor II

Hey folks, I hope you can help me out.

I have been messing around with the Traverse tool and I have hit a bit of a snag. I have my traverse set up to take the delta as the final parameter for my curve, but my description gave me arc length and chord length. When I try to use the chord override - 119c it still uses dms as units and I end up with 119° 00' 00" when I hit enter.

Here are some screen shots:

Which gives me this when I hit enter:

Before you say "Change the dms to feet.", I tried, it only offers angle units - dd, dms, ra.

I like to use the delta angle for my go to curve parameter, so I need to be able to override it when it isn't given to me in the description. I get the same behavior when I use the arc length override.

I should mention, I am editing a line feature class that has COGO attributes, not a parcel fabric.

Am I missing a setting?

Thanks

Jeff Ward
Summit County, Utah
0 Kudos
1 Solution

Accepted Solutions
TimHodson
Esri Contributor

Jeff,

Thanks for reporting this. I have been able to reproduce the problem and confirm it is a bug. There is a fairly simple workaround. The bug is that when the column is using a Delta Angle, then if you use the “c“ override to indicate a chord distance, the distance is getting a unit angle conversion applied, because the grid cell still "thinks" it’s in an angular unit. The specific criteria are:

  1. Second Curve Parameter column is set to Delta Angle
  2. The unit drop down is "dms"

Workaround: Before applying the "c" override, set the unit drop-down in the cell to "dd" (decimal degrees) - this way the numbers after the decimal point are not parsed as minutes and seconds, and this bypasses the bug.

-Tim

View solution in original post

2 Replies
TimHodson
Esri Contributor

Jeff,

Thanks for reporting this. I have been able to reproduce the problem and confirm it is a bug. There is a fairly simple workaround. The bug is that when the column is using a Delta Angle, then if you use the “c“ override to indicate a chord distance, the distance is getting a unit angle conversion applied, because the grid cell still "thinks" it’s in an angular unit. The specific criteria are:

  1. Second Curve Parameter column is set to Delta Angle
  2. The unit drop down is "dms"

Workaround: Before applying the "c" override, set the unit drop-down in the cell to "dd" (decimal degrees) - this way the numbers after the decimal point are not parsed as minutes and seconds, and this bypasses the bug.

-Tim

View solution in original post

JeffWard
Regular Contributor II

Thanks for the update Tim. Any idea when that bug will be fixed? It's not much of an override if I have to involve the mouse.

Jeff Ward
Summit County, Utah
0 Kudos