Why are my vector tile labels not appearing at certain scales in AGOL

941
3
11-12-2019 07:35 PM
MattSmith6
New Contributor III

My team currently maintains a series of cached raster basemaps over our state, and I've been experimenting with generating the same effect with vector tiles.

However, the generated hosted VTPK file renders differently inside ArcGIS online than it does when viewing the same layer. There are certain scales (in my case L10 and L15) where this occurs.

The first image is the ArcGIS Pro project at L15. It's still a work in progress, but I'm pretty happy with it so far.

The next image shows the VTPK hosted on ArcGIS Online over the same area at L15. The labelling is a little funky and not as precise or dense as the original - it stacks, overlaps and overruns where I don't really want it to, but whatever, it's early days.

 

The final image shows the same scale and extent, but via the AGOL viewer. As you can see, barely any labels (curiously the Depot Hill label is missing from the above image). And it doesn't matter whether I'm viewing the hosted layer via a map viewer or Web App. Or Chrome, Edge or Safari.

Any ideas on what might be causing this?

Link to the tiler layer: https://tiles.arcgis.com/tiles/HrMiNYsSqqPpLTDE/arcgis/rest/services/QldBase_Pastel_v2p1/VectorTileS... 

0 Kudos
3 Replies
Peter_Klingman
Esri Regular Contributor

Thanks Matt for the detailed post. I saw that you've already gotten your account attached, but for those who haven't we have two BUGs logged for this:

BUG-000118109 and BUG-000116950

Thanks,

Peter

0 Kudos
LiviaBetancourtMazur
New Contributor III

Hello! I am having a similar issue. I created a custom vector basemap. Everything appears as it should in map viewer (classic), WebApp builder, Field Maps, and the vector style editor. However, labels in that same exact vector basemap do not appear at certain scales in an instant app that I created. I tried looking at the app in an incognito window and in Chrome and Firefox, but the same issue is there. The same problem previously happened to me in map viewer too... so I am not sure where or how the issue is occurring. I tried to call ESRI support but I am not currently an authorized caller for my org. Peter, is there any way you can help me with this? (I would prefer to interact with you or another knowledgeable person, since ESRI support can sometimes be a pain to get connected to the right person, regardless of my authorization issue).

0 Kudos
LiviaBetancourtMazur
New Contributor III

Update: I think I might have figured out the problem. I had my custom vector basemap overlaid on top of an ESRI raster basemap. When I removed that other raster basemap layer, it solved the problem. I still don't fully understand what caused the problem since a) I used the ArcGIS Online/Bing/Google tiling scheme for my vector basemap and 2) the issue was only present in the instant apps. Anyway, sorry for mucking up this discussion with my random comments since it is a bit off topic to the original post  - I should probably just delete my comments but I thought I was leave up here in case someone else comes across the same issue. Thanks!

0 Kudos