Web Map (Beta) Won't Let Me Save

850
16
05-26-2021 10:16 AM
Labels (3)
Alexa
by
New Contributor

Hello,

I'm having an issue with a web map that was created via the "Share as Web Map" option in ArcGIS Pro. The layers are configured so that they can only be viewed in what was once called Map Viewer Beta (versus Map Viewer Classic) so that is what I use. But--every time I try to save the web map I get a message that says "An Error Occurred". This happens whether I try a flat save or a Save As.  There is no indication on what is causing the error. 

Does anyone have any insight? 

0 Kudos
16 Replies
RussellRoberts1
Esri Frequent Contributor

I cannot reproduce this. Can you share the map and I can take a look.

0 Kudos
Alexa
by
New Contributor

What is the best way for me to share it? I'm also noticing that when I share as a web map sometimes only one or two of my layers will be hosted. 

0 Kudos
RussellRoberts1
Esri Frequent Contributor

You can share it to a group and invite russell_jsapi to it and I can check out the web map & layers.

0 Kudos
Alexa
by
New Contributor

I gave it a try. I don't know what you might see--but when I shared the map more than half of my layers didn't host. I'm not sure why. They are all shapefiles in the same geodatabase, either point or line features. 

0 Kudos
RussellRoberts1
Esri Frequent Contributor

When you publish from Pro you can see if your map content in the sharing panel can you see if you can toggle the shapefile layers to be published as hosted feature layers?  Still looking into the saving issue but I think its something to do with the series of feature collections(shapefile layers) in the web map. 

0 Kudos
Alexa
by
New Contributor

Can you give me a little more guidance in how to do that? I don't see anything in the sharing pane. 

0 Kudos
RussellRoberts1
Esri Frequent Contributor

On the sharing pane - look at the Configuration and you can look at the layer properties for those shapefiles to see if they are being published as web layers. 

 

RussellRoberts1_0-1622123286107.png

 

0 Kudos
Alexa
by
New Contributor

It indicates that only some of them are being published as web layers. Also--and I'm not sure if this is helpful--when I right click on some of the layers in the Contents pane and go to Sharing, the ability to share them as a web layer is greyed out. Again, I'm not sure why as everything is in the same geodatabase. 

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Can you copy those shapefiles to a gdb and then try to publish that way? Might solve the issue with them not being all hosted. 

0 Kudos