View Layer not recognizing new fields added to Feature Layer

11-08-2019 11:21 AM
New Contributor

I have a Hosted Feature Layer that I have used to create 6 View layers. I recently added 2 fields to the Hosted Feature Layer; I did so on AGO from the Data tab. After adding those fields, I knew that I would have to update the View Definition in all my View layers if I wanted to be able to see and use those fields. I was able to do so successfully on 4 out of the 6 View layers, and I am not sure why it is not working on the last 2. The fields just do not show up in the Define Fields dialog.

This has happened to me more than once, and usually I just recreate the View to "fix" it, but one of the 2 View that are not working is shared publicly, and it's a bit of a pain to get things shared publicly in my Organization, I have to go through admins. So I though I would try to troubleshoot it a little bit before I go through the process of recreating and getting it shared publicly again.


1 Reply
Esri Regular Contributor

Hi Jeremy,

Though you may have already re-created the view by now, here are some troubleshooting ideas:

1. Are there any differences whatsoever between the 4 views that updated as expected and the 2 that didn't?

2. From the Overview page of the view, scroll down to URL on the right and click "View." Then click the link to the layer where you added the fields. Are both of these properties set to "true?" Is Updatable View, Source Schema Changes Allowed.

3. From here insert the word admin in between rest and services. Even without setting the new View Definition yet, I see all the new fields added at this endpoint. So my guess is that if the field is missing from here that explains why it's not present when you go to update the View Definition - it is not making it to this View at all. 

I hope that helps - I would definitely recommend getting in touch with Esri Support to look into this further if you are still interested in continuing to troubleshoot. Let me know if I can assist with getting a case created.