Unable to update a hosted feature layer with "Overwrite Entire Layer"

299
1
07-07-2020 12:20 PM
PedroOliveira
New Contributor

I'm trying to update a simple hosted feature layer based on an excel file directly in ArcGIS Online (no scripting).

As per the documentation here, I should be using the same file but with updated values within. I have tried modifying values and adding or removing rows, but I always get the same error:

"User cant overwrite this service, using this data, as this data is already referring to another service."

The only service this data may be referring to is this same one I'm trying to update.

Am I reading the documentation wrong or is there something I need to modify further in the file? I'm trying to update the feature layer with the same file used to upload before (plus cell/row changes) using the same fields.

0 Kudos
1 Reply
Peter_Klingman
Esri Regular Contributor

Hi Pedro Oliveira‌,

Looking at some internal technical support records, there are a couple of issues logged with renaming the source file geodatabase or shapefile, but I could not reproduce this with hosted feature layers created from Excel files. When you select the link from the Excel document in ArcGIS Online to view the associated service, does it link to the expected one?

This is definitely not expected behavior, so it may be best to contact Esri Support - an analyst can take a closer look at the layer and troubleshoot over a screen share. Let me know and I would be happy to assist in this process. 

Thanks,

-Peter 

0 Kudos