Unable to implement Password-based Single sign-on to ArcGIS Online application in Azure AD

221
0
05-11-2020 09:47 AM
RajeevRoy
New Contributor II
Problem Statement:
 
To implement "Password-based" single sign-on for "ArcGIS Online" using the Azure AD Gallery app.
Steps followed to implement this approach are described below through screenshots:
  1. In the Azure AD portal, we have generated a new Enterprise Application and choose the "ArcGIS Online" app from the gallery. Refer to the below screenshot.
    0_add_arcgis_online_gallery_app.png

  2. Selected the ArcGIS Online application from All applications option. 
    1_select_arcgis_online.png

  3. Choose the "Single sign-on" option from the left menu pane and select the "Password-based" method as depicted.
    4_ad_sign_on_method.png5_sign_on_url.png

  4. Selected the "Users and Groups" option from the left menu pane and added the desired Azure AD users in the application. For each of the users, ArcGIS Online credentials are configured using Update Credentials setting as depicted in the screenshot below:3_ad_update_credentials.png

  5.    We have tested the functionality by copying the User access URL in a new browser window. Note the browser already have the Azure AD account logged in another tab.
    9_copy_user_access_url.png 

  6. This URL redirects to the Microsoft page holds for few seconds and then redirects to the "ArcGIS Online" sign-in page where the username and password are not getting updated and the user is not logged in. 
    11_no-fields-populated-in-form.png

Kindly suggest how to fix the issue and achieve the Password-based SSO for ArcGIS Online.
0 Kudos
0 Replies