Select to view content in your preferred language

Unable to edit editable layer

3117
5
Jump to solution
03-21-2023 12:22 PM
LJackson29
Occasional Contributor III

Hi - 

Is anyone experiencing issues with editing hosted feature layers on ArcGIS online in the new map viewer today? I have a user that was able to edit a hosted feature layer last week, and today she is unable to edit it. There have been no changes to the editing status of the layer (editable), sharing (shared with a group she is a member of), her role has not changed (Mobile Worker/Data Editor), she is using the same computer and browser. We changed sharing to organization and that did not change anything, we cleared her cache in Chrome that did not work. We tested Creator/User and Publisher roles and they cannot edit either, only admins. We changed to map viewer classic and she was able to edit, but the edits did not save. Any suggestions?

Tags (3)
1 Solution

Accepted Solutions
LJackson29
Occasional Contributor III

Hi Peter -

Thanks for your reply. I think it was just occurring with this one hosted feature layer, but didn't check that until this morning. The issue was consistent. I exported the hosted feature layer and republished it today and the problem has resolved. Not sure what caused it.

Best,

Leila

View solution in original post

0 Kudos
5 Replies
PeterHodkinson
Esri Contributor

Hi Leila,

I'm sorry to hear about this issue.

  • Is this happening for all your hosted feature layers or just one?
  • Is the issue consistent or have you occasionally been able to save edits on the layer since the issue occurred?
  • Which services URL is the feature layer using? You can find this by opening the item details page and looking at the URL listed at the bottom of the page. For example it might begin with something like this: "https://services1.arcgis.com/..."

 

Many thanks,

Peter

0 Kudos
LJackson29
Occasional Contributor III

Hi Peter -

Thanks for your reply. I think it was just occurring with this one hosted feature layer, but didn't check that until this morning. The issue was consistent. I exported the hosted feature layer and republished it today and the problem has resolved. Not sure what caused it.

Best,

Leila

0 Kudos
PeterHodkinson
Esri Contributor

Great, I'm pleased to hear it's working for you again now.

Best wishes,

Peter

0 Kudos
MarioSchedler
New Contributor II

I have the same issue in AGE 10.9.1 and realized that I can edit a feature layer in a web map in Portal when it's not grouped. When I add a feature layer to a map, I can edit the layer. When I create a group, the Edit button is grayed out. Is this a bug?

0 Kudos
Justin_Richardson
New Contributor II

It must be, Mario. I've run into the same thing. Layers are non-editable when in groups in Map Viewer. They must be removed from a group before Editing is enabled. When it looks like a bug and smells like a bug...

0 Kudos