Trying to delete an obsolete group

03-24-2019 04:49 PM
New Contributor III

I created a group years ago that has not been used. When I try to delete the group (as the owner), I get this message: "This group cannot be deleted as it is used in your organization's settings." I don't understand what this means or what I should do to enable deletion of the group. I'd be grateful for guidance.


0 Kudos
5 Replies
by Anonymous User
Not applicable

There are several reasons you might be running into this error. If you are the admin of your ArcGIS Online organization, then I would look at the Organization > Settings tab to see if this group if configured for any settings, such as in Open Data or as a featured group. If you are not the admin, I would speak with your admin to investigate what it's configured for.

Hope this helps!

New Contributor III

Alexandra, I checked this and the group in question is not featured and Open Data is not enabled. However, when I tried to make minor changes to other items I got a message saying "cannot make changes at this time", so it's hard to tell whether something here is involved. Thanks for the suggestion.

0 Kudos
Esri Frequent Contributor

Hi Dan,

This is a bit complicated but should be a fast way to compare the groups you are using in your group settings with the group that you are trying to delete.

Either using developer tools‌ or generating your own url and appending a token:‌, make a portal self call:

Portal Self—ArcGIS REST API: Users, groups, and content | ArcGIS for Developers 

Example:<add token>

I'd suggest searching for either the Group ID or the group name in question to see where it is configured in your settings.


New Contributor II

Hi Dan,

I had the same problem. The Group I was trying to delete was a Featured Content Group. I received the same error message: "This group cannot be deleted as it is used in your organization's settings.". The problem turned out to be that the Group was set as a Feature Content Group in ArcGIS Online's previous legacy homepage configuration.  Go to the Organization page. Click on Settings. Click on Home page. Under Homepage editor there is another block which contains a hyperlink: "previous legacy home page configuration" Try clicking on that, scroll down to "Featured Content".  I changed mine to  "No featured content". Click done. I was then able to delete the group when I went back to the group page and clicked delete.



0 Kudos
New Contributor

If anyone is still running into this issue after the March 2022 update you can no longer change the legacy home page settings. The link will let you view your previous home page but no options to change the settings. If you have a Feature Content Group set you can configure it using the api in an ArcGIS Notebook. This will set the homePageFeaturedContent to a dummy group that does not exist and let you delete the current. 

from arcgis.gis import GIS
import requests

portal ="" #The short name uniquely defines the URL to your organization
username = "ADMIN_USERNAME"                  #input your admin username
password = "ADMIN_PASSWORD"                  #input the admin password

gis = GIS(portal, username, password)
token = gis._con.token

params = {"f": "json", "homePageFeaturedContent": "dummyGroup", "token":token}
res =, params)
resp = res.json()

print (resp)


0 Kudos