Trouble adding an onsite feature services in ArcGIS.COM map

3935
5
11-12-2014 03:41 PM
VishApte
Esri Contributor

Hi,

 

I am having a little issue in configuring AGOL map to be used in ArcGIS Collector app.

 

The map will have base map from AGOL and an editable feature service that is hosted on client’s own ArcGIS Server 10.2.2. This ArcGIS Server is externally available through Microsoft ISA Reverse Proxy with Web Adaptor and ArcGIS Server sitting behind the firewall. Web Adaptor in IIS is set-up as Windows Authentication. The external URL is accessed using https protocol. Web Adaptor and ArcGIS server are also configured in https-only mode. ArcGIS Server security is configured in Windows Tier mode. The service I am testing is not secured at this time but eventually it will be.

 

I can edit feature service data externally over REST API . Also add feature service to ArcMap running outside of the client's network, edit the data and sync it back. So it proves the set-up is correct.

 

However, when I add this feature service to AGOL map, AGOL sends warning saying

 

Layers
-  Collector_Trial_Dataset.Drainage

-  Collector_Trial_Dataset.WaterBody

seem to be on an internal network and are not accessible to ArcGIS.com. Thus, editing will be disabled on these layers.

 

However, AGOL shows the data in the map and I can identify/query it. So what causes AGOL to infer this feature service is on internal network?

 

If I turn https to http all along and also set-up Web Adaptor in IIS to use anonymous authentication instead of Windows Authentication, editing works in AGOL.

 

I have seen this thread below but I have also seen presentations that say Collector can consume secured feature services.

How to edit SDE layers

 

Any help to resolve this issue is greatly appreciated.

 

Cheers,

Vish

Tags (2)
0 Kudos
5 Replies
SimoXu1
New Contributor II

Hi Vish,

Have you solved the problem? I am running into the same issue.

My setup is quite similar to yours: reverse proxy to allow internet users to access my internal GIS services. I made a webmap using my internal feature service in AGOL.

Everything works fine when I am inside of my corporate network, but if I leave my corporate network and try to access the webmap from the open internet, I will have the error you had despite I can view the service (some dots) in the webmap.

I am quite puzzled, is there any technical difficulties which restrict AGOL from editing a internal feature service ?

0 Kudos
SimoXu1
New Contributor II

It's a bug

please see @Jake Skinner 's post in

Can not edit service In ArcGIS.com

0 Kudos
KellyGerrow
Esri Frequent Contributor

Hi Simo,

The bug that is referred to in the post above is a limitation of browsers without Cors. This specific issue will only be present in IE8 and IE9. Are you experiencing this issue in either of those browsers?

If you are using a browser that is not one of the browsers above, check the security that is set on your ArcGIS Server

What type of server security are you using? Is it token based security or Web Tier Security. ArcGIS Online supports ArcGIS Server authentication and not Web Tier Authentication. Adding an editable service that uses web tier authentication can result in the error message mentioned above.

Also, feel free to contact Esri Support Services for further help troubleshooting this issue.

-Kelly

SimoXu1
New Contributor II

Hi Kelly,

Thanks for your reply.  I tried latest Chrome and Firefox, neither of them is working on this. those browsers should be CORS-enabled.

I don't really know what kind of security we are using on the GIS servers, but it seems the services are NOT secured services (they may filter the requests in the front end fireware to make sure only requests with certain referrals can come through), AGOL didn't prompt for credential when I add the services in a map.

It seems a networking issue, because it matters where I access the internet from, if inside of my organisation, there are no problems, if form a cellular phone network (outside of my organisation network) it stops working.

Cheers,

Simo

0 Kudos
ShaunConway
Occasional Contributor II

Kelly,

I am also experiencing this issue and I am using the latest version of Firefox and Chrome and have just upgraded to IE11.

Any suggestions?

0 Kudos